Support » Plugin: WP Show Site by IP » Not working with ssl ?

  • Resolved Commeuneimage

    (@commeuneimage)


    Hi,
    I’m trying to have it work but so far, I can’t see this plugin working at all (i.e. it remains visible from any IP).
    I was wondering if this was due to the fact that my website is accessible through HTTPS (but I’m not sure of that).

    Also, I was disappointed not to have a page with the white list of authorized IP (and the ability of removing/adding IP addresses manually).

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author d79

    (@d79)

    Hi and thanks for the feedback.
    HTTPS is not a problem (all my websites that are using this plugin are on HTTPS).
    In order to make it work it should be enough to install and activate the plugin, then enable the filter with the relative option in the settings page (/wp-admin/tools.php?page=wssbi).
    As for the whitelist you are right, it would be handy: I’m placing it on my todo list and I’ll try to make it asap.

    Let me know if the issue persists.

    Thread Starter Commeuneimage

    (@commeuneimage)

    Thank you for your quick answer.
    Of course the plugin is installed and activated and configured (I changed the “string OK” setting for more security) and the reminder in the admin page is present: Warning: the filter by IP is enabled. Your users are seeing the temporary page instead of your website. )!
    I even had a quick look to the code to understand what could possibly go wrong (I anticipated a modification of .htaccess, I was wrong).

    So it was something else… and I’ve just found it after a discussion with the network guy of my company. All incoming flows come (unfortunately) with the same IP from a proxy… So there is no issue in your plugin but I need to find another way to filter the traffic!

    Good luck (and fine if you take benefit of my feature proposal :))

    Kind regards

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not working with ssl ?’ is closed to new replies.