Support » Plugin: YITH WooCommerce Ajax Product Filter » Not working with RTL slugs

  • Hi. Not only there are some visual issues in RTL sites, but there’s a functionality issue too. If the attribute slug is written in an RTL language, the filters don’t update well. (adding works, removing doesn’t).

    This issue has been around for at least 7 months now.

    previous versions (from 7 months ago) worked fine.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi,

    with some theme or in general with non latin chars the plugin, sometimes, have a little problem. Some of our user solve the issue in this way:

    https://support.yithemes.com/hc/en-us/articles/115003505787-Ajax-Product-filter-does-not-work-with-Non-Latin-Character

    Please, can you try this solution and let me know ?
    Thanks
    Have a nice day
    YITH

    Thread Starter miladgh

    (@miladgh)

    Hi and thanks for the quick reply.
    Unfortunately the issue is not fixed.
    These are the things I’ve tried based on that article:
    1- Adding that 1 line of code to function.php
    2- Adding that few lines of code without that single line
    3- Adding both the single line and those multiline codes.
    4- Tried 1, 2 and 3 with child theme and main theme.

    Environment Details:
    – WordPress 4.8
    – Avada 5.1.6 (latest version)
    – Site language: Persian/Farsi
    – WooCommerce 3.0.8
    – Along with persian wordpress/ persian woocommerce complementary plugins.

    Is there any other way or any other code I can try? I really love this plugin and in-fact there’s nothing on the market as good as this.

    With some custom CSS you can make it work as RTL

    Thread Starter miladgh

    (@miladgh)

    @delreyagency Thanks for the suggestion; but the main issue is not about styling; but rather the functionality of the plugin with non-latin characters when used as attribute slugs.

    @miladgh I’m sure the developer will solve it fast but if the issue is connected with plugin functionality, we can check chrome debugger to get more information:

    http://i.imgur.com/vKyWX48.png

    Thread Starter miladgh

    (@miladgh)

    @yithemes @delreyagency I even tried Chrome debugger and it’s showing no errors. In the screencast below, you can see that when I choose an attribute which has an English name and slug, filtering and removing the filter works fine. But when I try to apply a filter with RTL characters as name and slug, the filter does get added but removing it does NOT work. Please take a look: https://streamable.com/ujwhf

    Plugin Author YITHEMES

    (@yithemes)

    Hi @miladgh,

    please visit this link: https://wordpress.org/plugins/yith-woocommerce-ajax-navigation/advanced/

    At the end of the page you find a dropdown with all older version of this plugin. Please, can you try if the previous version works fine ? If not, you can find a version that works fine…if you tell me the number of previous version that works fine I can ask to our developers to investigate about this strange issue.

    Let me know
    Have a nice day
    YITH

    Thread Starter miladgh

    (@miladgh)

    @yithemes Thanks for getting back to me.
    I have another website (with older version of WordPress and plugin and stuff) that this plugin works on it. The working version is 5.9.2
    When I try this version on my new site, no filter is shown in frontend.
    The next version is version 3.0.0 and when I use that version, the issue is there.

    So, I’m guessing that maybe after 5.9.2 it stopped working.

    And 1 important thing, the main focus of issue in this topic is with dropdown filters. Label and List filter works fine.

    Plugin Author YITHEMES

    (@yithemes)

    Hi,

    The working version is 5.9.2

    Our team have never release the version 5.9.2, please can you check the version again ?

    Thanks.

    Have a nice day

    YITH

    Thread Starter miladgh

    (@miladgh)

    @yithemes sorry the last version I meant was 2.9.2
    It was a typo.

    Plugin Author YITHEMES

    (@yithemes)

    Hi,

    you can download thie version from here: https://downloads.wordpress.org/plugin/yith-woocommerce-ajax-navigation.2.9.2.zip

    Have a nice day

    YITH

    Thread Starter miladgh

    (@miladgh)

    @yithemes based on your latest answer, I think you’ve misunderstood the topic.
    You asked for the last working version so your developers can investigate the issue.
    I do have access to 2.9.2.
    The problem is the newest version of this plugin has a problem with arabic/persian characters as explained in detail above.

    Plugin Author YITHEMES

    (@yithemes)

    Hi,

    today our team released a new version and the problem seems to be solved.
    please can you try this new version ?

    Have a nice day
    YITh

    Thread Starter miladgh

    (@miladgh)

    @yithemes Hi. I tried it and the issue still exist. 🙁

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Not working with RTL slugs’ is closed to new replies.