WordPress.org

Support

Support » Plugins and Hacks » Advanced Access Manager » [Resolved] Not Working with Latest Update!

[Resolved] Not Working with Latest Update!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Vasyltech

    @vasyl_m

    Hi pgale2,
    I’m sorry to hear that. Under Features/Plugins do you mean AAM Plugin Manager add-on or this is a menu?
    Regards,
    Vasyl

    We hide the majority of plugin accessibility from non-admins using the Advanced Access Manager.

    For example, previously, we are able to hide all of Jetpack features, except for Jetpack stats.

    We were able to hide the majority of “Settings”, and allow access only to “General, Writing, Reading.”

    We were able to hide all the settings for WordPress SEO by Yoast but still allow SEO functionality from within individual blog posts / pages.

    With the latest update of AAM, all the Settings, all of Jetpack and all of WP SEO are now all visible to non-admins in the WP dashboard.

    Plugin Author Vasyltech

    @vasyl_m

    Hi pgale2,
    This may be related to caching migration. It has been moved to database.
    I’ll check this issue tonight and will contact you if find something.
    Try to select Current Role Editors (I believe the proper settings still remain for Editors) and hit Save.

    Regards,
    Vasyl

    Plugin Author Vasyltech

    @vasyl_m

    Hi pgale2,
    Most likely I found the cause of the issue. The fix will be included in tonight’s release 1.7.1.
    To make sure that this will help, please do me a favor, go to advanced-access-manager/model/cache.php file to the line 84 and replace it with next line of code:
    $wpdb->query(“DELETE FROM {$wpdb->options} WHERE option_name LIKE ‘” . WPACCESS_PREFIX . “user_%'”);

    Regards,
    Vasyl

    Thank you! I’m not much of a coding expert, so I’ll just wait for the update.

    I truly appreciate you addressing this so quickly.

    Thank you!

    Reporting that the suggested fix is not working. There seems to be a problem with the latest version of Adminize as well.

    As a result the latest version of WordPress has no decent permissions plug-in, which isn’t the fault of the plug-in authors ofcourse – you guys are doing the right thing!

    Things like adjustable permissions should be native to a WordPress installation (as it is with Drupal).

    I uninstalled it (removed the plugin and data), but apparently the AAM permissions policy lives on after a removal. Installed it again, took a look at the permissions and indeed: some additional permission were still checked (performed as a test) – and working, while these were the ones that shouldn’t. Quite sketchy all this.

    The thing I’m trying to achieve is to allow the editor to manage the main menu. Unhecked the whole brach of Display (main menu tab) to no avail. Checked “Activate plugins” (capabilities tab tab) as test, works (after removal, huh?), but shouldn’t be assigned (especially not after removing the plugin).

    When I click one of the role-buttons below the capabilities page, I’m seeing checked boxes that are disappearing where they shouldn’t, it’s not aligned with the default permissions of additional plugins apparently (nextgen gallery in my case). Not cool.

    Hi.

    I’m trying to let Editor users to not be allowed anywhere in Appearences, but the Menus. Then I unchecked this and let the others checked.

    But still, the Editor user can’t see the Menus option in admin sidebar.

    It used to work, I guess it’s something bad with the 1.8.3 version.

    Please fix it!

    Thank you!

    Hi,

    I am just seeing a white screen, when I try to access Advanced Access Manager.

    Since updating WordPress 3.5.1. Advanced Access Manager does not work. I have even totally uninstalled the Plugin and installed the new Version 1.7.3 which is newer than the version mentioned above which was meant to fix recent problems, but unfortunately still not working.

    This was a fantastic plugin and don’t know of anything else that can do what this one does, so would really appreciate some help on this.

    Many thanks

    Hi, I have just installed a fresh wordpress site, and then installed Advanced Access Manger and it worked. Perhaps there is a template or plugin conflict. I will look into this some more and update…

    Hi, tried uninstalling ALL other plugins and switching to the default theme, but this had no affect?

    Would welcome any suggestions

    Desperately need a solution

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Not Working with Latest Update!’ is closed to new replies.
Skip to toolbar