Support » Plugin: Book Review Block » Not working with Gutenberg

  • Resolved zarahoff

    (@zarahoff)


    I keep getting this error: “This block has encountered an error and cannot be previewed.” which really sucks because I need this widget for my blog.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • Hi Zarahoff and Donna,

    I am having this same exact issue with my blog. I want to keep using this plugin instead of purchasing one somewhere else, but I seem to get that same “error” message EVERY TIME I write something in the description section. I activated the plugin itself and it is currently at the 1.2.1 version and Guttenberg is updated as well. Please Donna, help us out. I am sure we all want to keep using your plugin because of how beautiful, elegant, and easy it is to use, but it is frustrating that we cannot seem to be able to use it right now because of the error message we keep getting.

    Plugin Author Donna Peplinskie

    (@donnapep)

    Hi Zarahoff and Cristina,

    The issues you were experiencing are fixed in version 1.2.2.

    Please note that if you are on a version of WordPress that is 5.0 or higher, then you no longer need the Gutenberg plugin installed.

    Thx.

    So should we deactivate Guttenberg for it to work? I started using your old book review block and it does the job just fine. Before I try to use the newer version I want to make sure I know what I need to use.

    Thank you!

    Plugin Author Donna Peplinskie

    (@donnapep)

    It will work with or without the Gutenberg plugin installed if you’re on WordPress 5.0+, as long as you’re not using the Classic Editor plugin to disable the new editor.

    Please note that I will not be maintaining Book Review going forward, only Book Review Block. So if something should break with it in the future, there will not be an update to fix it.

    Cheers.

    I deactivated Gutenberg (I’m using 5.0+) and I’m getting an error that reads “The editor has encountered an unexpected error” with buttons to Attempt Recovery, Copy Post Text, or Copy Error while also hiding everything else in the post (I have to leave the page, and then go back to editing the post from the menu). What should I do?

    But the weird part is that it works on one of my websites, but not on the other. They’re both using the same theme, too.

    zarahoff

    (@zarahoff)

    Okay. Ignore my last 2 comments, @donnapep. It now appears in editor for both sites, but not in the actual post when I view it.

    Plugin Author Donna Peplinskie

    (@donnapep)

    It now appears in editor for both sites, but not in the actual post when I view it.

    Can you please provide a link to a page on your site where the post is not showing?

    Thx.

    I’m having the same problem with it showing up in my editor but not in the published post. Here‘s an example from my site.

    For me, there was a problem in wp-includes. Downloading a fresh install of WordPress, and replacing my wp-includes folder solved the problem. Apparently, sometimes the problem is with wp-includes/.htaccess. That wasn’t the problem for me, but you might want to check that first.

    I have the same problem as @readingthroughlife : In the editor I can fill out the block, but nothing from the block appears when I preview or publish the post.

    This is my review section

    Plugin Author Donna Peplinskie

    (@donnapep)

    Please upgrade to 1.2.3 to get the fix for this. Thanks and apologies for the inconvenience/confusion.

    Hi Donna,

    1.2.3 fixed the problem for me. Thanks.

    Lars

    @donnapep I tried reinstalling WordPress as @dcrabill recommended and I’ve updated the plugin to 1.2.3 and it still doesn’t appear for me. https://zarahoffman.com/2019/01/07/soul-in-darkness-by-wendy-higgins-arc-review/

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Not working with Gutenberg’ is closed to new replies.