Support » Plugin: WP Mail SMTP by WPForms » Not working with Google Apps for Business

  • Looks like this is an authentication error. The “access for less secure apps” option is not available in Google Apps for business. Is there a way to get this working without enablign 2 factor authentication ?

    Debug Below:
    —————————-
    Test Message Sent
    The result was:
    bool(false)
    The full debugging output is shown below:
    object(PHPMailer)#573 (69) {
    [“Version”]=>
    string(5) “5.2.7”
    [“Priority”]=>
    int(3)
    [“CharSet”]=>
    string(5) “UTF-8”
    [“ContentType”]=>
    string(10) “text/plain”
    [“Encoding”]=>
    string(4) “8bit”
    [“ErrorInfo”]=>
    string(35) “SMTP Error: Could not authenticate.”
    [“From”]=>
    string(21) “info@anuttarayoga.com”
    [“FromName”]=>
    string(13) “Anuttara Yoga”
    [“Sender”]=>
    string(21) “info@anuttarayoga.com”
    [“ReturnPath”]=>
    string(0) “”
    [“Subject”]=>
    string(51) “WP Mail SMTP: Test mail to michael.rajhel@gmail.com
    [“Body”]=>
    string(68) “This is a test email generated by the WP Mail SMTP WordPress plugin.”
    [“AltBody”]=>
    string(0) “”
    [“Ical”]=>
    string(0) “”
    [“MIMEBody”:protected]=>
    string(69) “This is a test email generated by the WP Mail SMTP WordPress plugin.

    [“MIMEHeader”:protected]=>
    string(449) “Date: Sun, 9 Nov 2014 06:33:38 +0000
    Return-Path:
    To: michael.rajhel@gmail.com
    From: Anuttara Yoga
    Subject: WP Mail SMTP: Test mail to michael.rajhel@gmail.com
    Message-ID: <51f0d1b17ec404e5beee1c586d5cb04d@www.anuttarayoga.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
    MIME-Version: 1.0
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit


    [“mailHeader”:protected]=>
    string(0) “”
    [“WordWrap”]=>
    int(0)
    [“Mailer”]=>
    string(4) “smtp”
    [“Sendmail”]=>
    string(18) “/usr/sbin/sendmail”
    [“UseSendmailOptions”]=>
    bool(true)
    [“PluginDir”]=>
    string(0) “”
    [“ConfirmReadingTo”]=>
    string(0) “”
    [“Hostname”]=>
    string(0) “”
    [“MessageID”]=>
    string(0) “”
    [“MessageDate”]=>
    string(0) “”
    [“Host”]=>
    string(14) “smtp.gmail.com”
    [“Port”]=>
    string(3) “465”
    [“Helo”]=>
    string(0) “”
    [“SMTPSecure”]=>
    string(3) “ssl”
    [“SMTPAuth”]=>
    bool(true)
    [“Username”]=>
    string(21) “info@anuttarayoga.com”
    [“Password”]=>
    string(13) “RamaHanuman11”
    [“AuthType”]=>
    string(0) “”
    [“Realm”]=>
    string(0) “”
    [“Workstation”]=>
    string(0) “”
    [“Timeout”]=>
    int(10)
    [“SMTPDebug”]=>
    bool(true)
    [“Debugoutput”]=>
    string(4) “echo”
    [“SMTPKeepAlive”]=>
    bool(false)
    [“SingleTo”]=>
    bool(false)
    [“SingleToArray”]=>
    array(0) {
    }
    [“do_verp”]=>
    bool(false)
    [“AllowEmpty”]=>
    bool(false)
    [“LE”]=>
    string(1) “

    [“DKIM_selector”]=>
    string(0) “”
    [“DKIM_identity”]=>
    string(0) “”
    [“DKIM_passphrase”]=>
    string(0) “”
    [“DKIM_domain”]=>
    string(0) “”
    [“DKIM_private”]=>
    string(0) “”
    [“action_function”]=>
    string(0) “”
    [“XMailer”]=>
    string(0) “”
    [“smtp”:protected]=>
    object(SMTP)#633 (12) {
    [“Version”]=>
    string(5) “5.2.7”
    [“SMTP_PORT”]=>
    int(25)
    [“CRLF”]=>
    string(2) “

    [“do_debug”]=>
    bool(true)
    [“Debugoutput”]=>
    string(4) “echo”
    [“do_verp”]=>
    bool(false)
    [“Timeout”]=>
    int(10)
    [“Timelimit”]=>
    int(30)
    [“smtp_conn”:protected]=>
    int(0)
    [“error”:protected]=>
    NULL
    [“helo_rply”:protected]=>
    NULL
    [“last_reply”:protected]=>
    string(57) “221 2.0.0 closing connection l2sm12510188qao.34 – gsmtp

    }
    [“to”:protected]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(24) “michael.rajhel@gmail.com”
    [1]=>
    string(0) “”
    }
    }
    [“cc”:protected]=>
    array(0) {
    }
    [“bcc”:protected]=>
    array(0) {
    }
    [“ReplyTo”:protected]=>
    array(0) {
    }
    [“all_recipients”:protected]=>
    array(1) {
    [“michael.rajhel@gmail.com”]=>
    bool(true)
    }
    [“attachment”:protected]=>
    array(0) {
    }
    [“CustomHeader”:protected]=>
    array(0) {
    }
    [“lastMessageID”:protected]=>
    string(55) “<51f0d1b17ec404e5beee1c586d5cb04d@www.anuttarayoga.com>”
    [“message_type”:protected]=>
    string(5) “plain”
    [“boundary”:protected]=>
    array(3) {
    [1]=>
    string(35) “b1_51f0d1b17ec404e5beee1c586d5cb04d”
    [2]=>
    string(35) “b2_51f0d1b17ec404e5beee1c586d5cb04d”
    [3]=>
    string(35) “b3_51f0d1b17ec404e5beee1c586d5cb04d”
    }
    [“language”:protected]=>
    array(18) {
    [“authenticate”]=>
    string(35) “SMTP Error: Could not authenticate.”
    [“connect_host”]=>
    string(43) “SMTP Error: Could not connect to SMTP host.”
    [“data_not_accepted”]=>
    string(30) “SMTP Error: data not accepted.”
    [“empty_message”]=>
    string(18) “Message body empty”
    [“encoding”]=>
    string(18) “Unknown encoding: “
    [“execute”]=>
    string(19) “Could not execute: “
    [“file_access”]=>
    string(23) “Could not access file: “
    [“file_open”]=>
    string(33) “File Error: Could not open file: “
    [“from_failed”]=>
    string(35) “The following From address failed: “
    [“instantiate”]=>
    string(36) “Could not instantiate mail function.”
    [“invalid_address”]=>
    string(15) “Invalid address”
    [“mailer_not_supported”]=>
    string(25) ” mailer is not supported.”
    [“provide_address”]=>
    string(54) “You must provide at least one recipient email address.”
    [“recipients_failed”]=>
    string(45) “SMTP Error: The following recipients failed: “
    [“signing”]=>
    string(15) “Signing Error: “
    [“smtp_connect_failed”]=>
    string(22) “SMTP connect() failed.”
    [“smtp_error”]=>
    string(19) “SMTP server error: “
    [“variable_set”]=>
    string(30) “Cannot set or reset variable: “
    }
    [“error_count”:protected]=>
    int(2)
    [“sign_cert_file”:protected]=>
    string(0) “”
    [“sign_key_file”:protected]=>
    string(0) “”
    [“sign_key_pass”:protected]=>
    string(0) “”
    [“exceptions”:protected]=>
    bool(true)
    }
    The SMTP debugging output is shown below:
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “220 mx.google.com ESMTP l2sm12510188qao.34 – gsmtp
    “SMTP -> get_lines(): $data is “220 mx.google.com ESMTP l2sm12510188qao.34 – gsmtp
    “SMTP -> FROM SERVER:220 mx.google.com ESMTP l2sm12510188qao.34 – gsmtp
    CLIENT -> SMTP: EHLO http://www.anuttarayoga.com
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “250-mx.google.com at your service, [104.131.45.14]
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    “SMTP -> get_lines(): $str is “250-SIZE 35882577
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    “SMTP -> get_lines(): $str is “250-8BITMIME
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    “SMTP -> get_lines(): $str is “250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    “SMTP -> get_lines(): $str is “250-ENHANCEDSTATUSCODES
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    “SMTP -> get_lines(): $str is “250-PIPELINING
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    “SMTP -> get_lines(): $str is “250-CHUNKING
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-CHUNKING
    “SMTP -> get_lines(): $data was “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-CHUNKING
    “SMTP -> get_lines(): $str is “250 SMTPUTF8
    “SMTP -> get_lines(): $data is “250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-CHUNKING
    250 SMTPUTF8
    “SMTP -> FROM SERVER:250-mx.google.com at your service, [104.131.45.14]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-CHUNKING
    250 SMTPUTF8
    CLIENT -> SMTP: AUTH LOGIN
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “334 VXNlcm5hbWU6
    “SMTP -> get_lines(): $data is “334 VXNlcm5hbWU6
    “SMTP -> FROM SERVER:334 VXNlcm5hbWU6
    CLIENT -> SMTP: aW5mb0BhbnV0dGFyYXlvZ2EuY29t
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “334 UGFzc3dvcmQ6
    “SMTP -> get_lines(): $data is “334 UGFzc3dvcmQ6
    “SMTP -> FROM SERVER:334 UGFzc3dvcmQ6
    CLIENT -> SMTP: UmFtYUhhbnVtYW4xMQ==
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “535-5.7.8 Username and Password not accepted. Learn more at
    “SMTP -> get_lines(): $data is “535-5.7.8 Username and Password not accepted. Learn more at
    “SMTP -> get_lines(): $data was “535-5.7.8 Username and Password not accepted. Learn more at
    “SMTP -> get_lines(): $str is “535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 l2sm12510188qao.34 – gsmtp
    “SMTP -> get_lines(): $data is “535-5.7.8 Username and Password not accepted. Learn more at
    535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 l2sm12510188qao.34 – gsmtp
    “SMTP -> FROM SERVER:535-5.7.8 Username and Password not accepted. Learn more at
    535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 l2sm12510188qao.34 – gsmtp
    SMTP -> ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. Learn more at
    535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257 l2sm12510188qao.34 – gsmtp
    CLIENT -> SMTP: QUIT
    SMTP -> get_lines(): $data was “”SMTP -> get_lines(): $str is “221 2.0.0 closing connection l2sm12510188qao.34 – gsmtp
    “SMTP -> get_lines(): $data is “221 2.0.0 closing connection l2sm12510188qao.34 – gsmtp
    “SMTP -> FROM SERVER:221 2.0.0 closing connection l2sm12510188qao.34 – gsmtp

    https://wordpress.org/plugins/wp-mail-smtp/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi rnexussix,

    I just installed did a fresh installation of this plugin and I am using Google Business App.

    Please make sure you have the following settings:

    -> Send all WordPress emails via SMTP. = true

    -> smtp host: smtp.gmail.com

    -> port: 587

    -> Use TLS encryption. This is not the same as STARTTLS. For most servers SSL is the recommended option

    -> Yes: Use SMTP authentication.

    Hello gcaruana,
    Tried your setting but still no go. Getting authentication error.

    Was able to narrow this problem down when I tested with generic google account.

    Authentication fails with “Access for less secure apps” disabled (default). https://www.google.com/settings/u/3/security/lesssecureapps?hl=en

    With “Access for less secure apps” enabled, both SSL and TLS work fine.

    Here is the problem” “Access for less secure apps” setting is not available under Google Apps for business.

    I think I am facing the same problem here, but the messages are different. My configurations are:

    • From Email: site@mydomain.com
    • From Name: My Site
    • [Checked] Send all WordPress emails via SMTP.
    • [Checked] Set the return-path to match the From Email
    • SMTP Host: smtp.gmail.com
    • SMTP Port: 587
    • Encryption: Use TLS encryption.
    • Authentication: Yes: Use SMTP authentication.
    • Username: site@mydomain.com
    • Password: <myPassword>
    The SMTP debugging output is shown below:
    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

    My WordPress Version: 4.0.1
    Plugin Version: 0.9.5
    PHP Version: 5.4

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not working with Google Apps for Business’ is closed to new replies.