Support » Plugin: HandL UTM Grabber » Not Working with Formidable Forms

  • Resolved madfoxphotobooth

    (@madfoxphotobooth)


    Hi Haktan –

    I’ll preface this all by saying I’m truly a novice at this whole thing so I’m thinking the real issue is I have no idea what I’m doing.

    I activated your plug in and am currently using the free version of formidable forms. I have set up a hidden field and called it [utm_source], I also put utm_source as the field key. I then went to my test page that I embeded the form on (using a UTM in the URL of course) and its not pushing through to my form entry. Is there something else that I’m supposed to be doing to get this to work?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Haktan Suren

    (@haktansuren)

    You should not use shortcode in your form…

    You should use the input field wrapper instead as it is described here https://www.haktansuren.com/handl-utm-grabber/

    Example in your case:
    [utm_source_i]<input type=”hidden” name=”utm_source” value=”%s” />[/utm_source_i]

    Hey Haktan –

    Thanks for the reply. Again I apologize for my lack of technical knowledge. I think I’m a bit confused.

    Am I supposed to be inputting the following code into the form or onto the page?

    Also can you confirm that this is the code I should be copy/pasting (ie should I be using the entirety of this code in its current form or do I need to edit it at all / get rid of pieces)?

    [utm_campaign_i]<input type=”hidden” name=”utm_campaign” value=”%s” />[/utm_campaign_i]
    [utm_source_i]<input type=”hidden” name=”utm_source” value=”%s” />[/utm_source_i]
    [utm_term_i]<input type=”hidden” name=”utm_term” value=”%s” />[/utm_term_i]
    [utm_medium_i]<input type=”hidden” name=”utm_medium” value=”%s” />[/utm_medium_i]
    [utm_content_i]<input type=”hidden” name=”utm_content” value=”%s” />[/utm_content_i]
    [gclid_i]<input type=”hidden” name=”gclid” value=”%s” />[/gclid_i]

    [handl_original_ref_i]<input type=”hidden” name=”handl_original_ref” value=”%s” />[/handl_original_ref_i]
    [handl_landing_page_i]<input type=”hidden” name=”handl_landing_page” value=”%s” />[/handl_landing_page_i]
    [handl_ip_i]<input type=”hidden” name=”handl_ip” value=”%s” />[/handl_ip_i]
    [handl_ref_i]<input type=”hidden” name=”handl_ref” value=”%s” />[/handl_ref_i]
    [handl_url_i]<input type=”hidden” name=”handl_url” value=”%s” />[/handl_url_i]

    If the above code is supposed to go on the form I’m using formidable forms and when I input a hidden field into the form there are limited settings for me to adjust. I can name the field (currently named “[utm source]”), I can change the field type (the field type is currently “hidden field”] and then there is field key (I don’t really know what this part does but I have input “utm_source”). Am I supposed to copy/paste the above code into the field key setting or is that incorrect?

    If the code is supposed to go on the page itself, I’m using beaver builder site builder (its a drag and drop WSYWG editor). The form is dropped onto that page in one container (text/css module). Below I tried to put another container for HTML where I just copy / pasted the code above and then tested it to see if it worked and it didn’t.

    Any suggestions on where to put this code?

    Again thank you so much for all your help with this!

    Plugin Author Haktan Suren

    (@haktansuren)

    Hi @madfoxphotobooth

    DM me via https://www.haktansuren.com/slack-handlwp/, so i can get you the custom version of the plugin that works for you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not Working with Formidable Forms’ is closed to new replies.