Support » Plugin: Widget CSS Classes » Not working with created widgetized area

  • Resolved oguido

    (@oguido)


    Hello,
    I just created a widget area with this method:

    <?php if ( !function_exists(‘dynamic_sidebar’) || !dynamic_sidebar(“Header”) ) : ?>
    <?php endif;?>

    And it works for my widgets. but trying to add css classes with your plugin isn’t working. Can you help me please?

    Thank you!

    • This topic was modified 10 months, 1 week ago by oguido.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @oguido

    First all, no need to check if dynamic_sidebar exists. It’s a WP core function.

    The issue is most likely due to how you register your sidebar. The parameters need to be set correctly. See FAQ: “Why aren’t the classes showing up in my widget?”

    Alternatively you could try checking “Fix widget parameters” setting and see if that works. It’s a feature that automatically tries to fix the widget parameters.

    Cheers, Jory

    oguido

    (@oguido)

    Great, thank you very much Jory. The “fix widget parameters” worked perfectly 😉

    About the way I registered I did it following an online tutorial… xD

    Thanks a lot again and great work. 5 stars!
    Cheers!

    • This reply was modified 10 months ago by oguido.
    Plugin Author Jory Hogeveen

    (@keraweb)

    No problem! Good to hear it worked for you as well.

    For more info about registering sidebars:
    https://codex.wordpress.org/Function_Reference/register_sidebar

    And thanks for the review!

    Cheers, Jory

    oguido

    (@oguido)

    👍😊

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working with created widgetized area’ is closed to new replies.