Support » Plugin: Invisible reCaptcha for WordPress » Not working with Contact Form 7

  • Resolved MechaWear

    (@mechawear)


    The spinner shows up and appears to be all good, but then I get hit with form spam.

    Am I missing something? Just install and activate the plugin? Is there a shortcode?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Russ

    (@gfxdesigner)

    You need to do the following:

    1. Setup a reCAPTCHA account at https://www.google.com/recaptcha
    2. In WordPress, go to Settings > Invisible reCaptcha > Settings and enter “Your Site Key” and “Your Secret Key” found from your Google reCAPTCHA account.
    3. Enable all chexkboxes under Settings > Invisible reCaptcha > WordPress
    4. Enable Contact Form 7 under Settings > Invisible reCaptcha > Contact Forms
    MechaWear

    (@mechawear)

    Did all those things. No luck. Deleted old site in Google recaptcha and started over.
    Checked V.3 box. Installed the key, secret and code… Waited a while for Google to catch up.

    Started seeing “Not enabled” notice where captcha should be. Then it showed up on my login page and wouldn’t allow me access to my site.

    Had to delete invisible recaptcha file via FTP to log in.

    Lame.

    heArt-coder

    (@heart-coder)

    V3 is much different and currently not supported by any plugin.
    1. Go back to reCAPTCHA account at https://www.google.com/recaptcha
    2. Select the reCAPTCHA v2 and invisible.
    3. Enter keys in plugin settings.
    4. Log-off and try logging in from wp-admin page.
    You should see the reCAPTCHA badge on bottom corner. Give it a second to load before hitting enter.
    Also check the frontend of your site. You should be able to see the badge on pages with log-in and comment forms. Try filling those forms logged off and if there is no badge you will get spam notifications. If that’s the case try another plugin.

    Excellent. Working now.

    So much better than making people identify store fronts. Hopefully the spam stops, too.

    Thanks for all the help.

    • This reply was modified 11 months, 4 weeks ago by MechaWear.

    OK.. So how do you get it to show up on the form? Is there a short code or does it appear on the options list for creating a form? I get everything else done and the get stuck here.

    MechaWear

    (@mechawear)

    Now the terrible identify a fire hydrant thing is back. I’m losing faith that this plugin can ever work.

    @thompsonaire
    All native, known and popular forms are supported by automated system. You just need to eneble from settings page of the plugin.

    For other forms you need to add functions to theme’s functions.php
    It is simple and instructed on plugin page: https://wordpress.org/plugins/invisible-recaptcha/

    @mechawear
    Install “Wordfence Security” plugin alongside this plugin. https://tr.wordpress.org/plugins/wordfence/
    Be careful with the settings for not blocking real users off your site. Start simple and activate options one by one and put enough time between to test them individually.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not working with Contact Form 7’ is closed to new replies.