Support » Plugin: Google Authenticator » Not working with 4.7.1

  • You can log in without typing the code once you upgrade to wp 4.7.1

    So be careful, plugin needs to be upgraded, at this time it’s a bug.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thank you!

    Hi, I just carried out a test and I can confirm that it is working for me. You might have a conflict somewhere in your site.

    Regards

    It’s working for me too.

    This gets reported a lot, and AFAIK it always turns out to be either user error, or a conflict with another plugin.

    @henrikschack, maybe there are some UI/UX/documentation changes the plugin could make so that people understood the required setup better? It could also probably detect if another plugin is hooking into authenticate, etc and warn about potential conflicts.

    I wish that were the case – but I use the app across 5 sites. It happened with each one. At first I thought it was a sync issue. However – nothing changed. Server times matched my phone – everything was great.

    I don’t use third party plugins. I write my own code. These two plugins are the only ones.

    @iandunn That would only work if my plugin gets installed last I guess.
    The “real fix” would be to include two-factor authentication in the WordPress core, instead of depending on plugins.

    • This reply was modified 2 years, 3 months ago by  Henrik Schack.

    I think something like this would catch it, since it would fire after all plugins (should) have registered their hook callbacks:

    function detect_plugin_conflicts() {
        global $wp_filter;
    
        // return early if current screen != profile.php
    
        if ( count( $wp_filter[ 'authenticate' ] ) > 1 ) {
             add_action( 'admin_notices', 'warn_user_about_conflicts' );
        }
    }
    add_action( 'plugins_loaded, 'detect_plugin_conflicts', 999 );

    You could even use something much later, like admin_init, or even admin_notices, to be even more safe.

    That’d probably be bad UX, since there’d be too many false positives, and that’d just scare/confuse users, but I’m just brainstorming ideas. Maybe instead you could just detect plugins with known conflicts, like that one that applies theme styles to wp-login.php.

    Hi, I’m sorry guys I finally found the problem for my case at least.

    I have a pre-production site for testing upgrades before deploying to production.

    I ended to disable the code in my user account on pre-production site to log easier and quicker. But as the plugin was stil activated it still showed the input on the admin page.

    When i upgraded to 4.7.1 on pre-production site, I then my plugins, and try to log in without code, i passed through, thinking the plugin was buggy on 4.7.1.

    So i din’t deploy 4.7.1 on production site, waiting for plugin update that didn’t come. So i posted on this forum.

    I believe there is no bug finaly, so if i could edit the title on this thread i would change it. Can I ?

    Thanks Henrik for your great piece of code !
    And thanks for the quick replied i get on this thread.

    I just want to add this incase anyone else is having same issue. I was having the same problem as @suncoding, and it turned out that I too did not have the plugin set to ‘active’ in the ‘Google Authenticator Settings’, found within the ‘User’ settings page. Further more, after setting it to active, I had to ‘Create a new secret’ and set-up Authenticator on my mobile device again, using the new QR code.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not working with 4.7.1’ is closed to new replies.