Support » Plugin: Alphabetic Pagination » Not working when only one result

  • Resolved Olly343434

    (@olly343434)


    Hi. I can get it to show the alphabet navigation, and it works fine when I click on a letter with multiple results, but when a letter only has one result the navigation disappears. Is there a fix for this?

    Also the pagination seems to merge with the first post on the list. I would ideally like it seperate. Do you have an idea on this?

    My site is at kubetest.kube.co.uk

    Thank you.

    https://wordpress.org/plugins/alphabetic-pagination/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Hi,

    Your site is not displaying the pagination or relevant page, can you please re-check it?

    Thanks,
    Fahad

    Hi,

    It is displaying on the following page:

    kubetest.kube.co.uk/display-posts

    Thank you.

    Oliver

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Hi,

    I got it, in fact last time this functionality was demanded by a user that if there is only one post so there shouldn’t be pagination appearance anymore. What i can do is; i will give this option in settings page that display pagination all times or hide when there is only 1 record. The second thing is a little ambiguous, please explain it that how first post is merging with the pagination? I am not sure but you might be talking about its layout?

    Thanks,
    Fahad

    Hi Fahad,

    Thank you. That would be a good solution. PLease let me know when this option will be available.

    For the second problem, when I do ‘inspect element’ in chrome developer tools, it shows that the alphabet navigation is INSIDE the first post item. I would prefer it to be outside the in its own div. Hope that makes sense.

    Thanks.

    Oliver

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Hi,

    I think this issue can be resolved by changing “DOM Position” field “#ID” of div. Try to play in settings area with DOM Position field. Make sure that you are giving a div #ID there in which pagination will be populated.

    Thanks,
    Fahad

    Hi again,

    I now have tried to set it to custom rather than auto and it stopped working altogether. kubetest.kube.co.uk/display-posts

    This is my index.php file in the child theme (I included a div with the id #ap-spot and specifeid this in the DOM position:

    <?php get_header(); ?>

    <section id=”content” role=”main”>
    <div id=”ap-spot”><?php echo do_shortcode(‘[ap_pagination]’); ?></div>
    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
    <?php get_template_part( ‘entry’ ); ?>
    <?php comments_template(); ?>
    <?php endwhile; endif; ?>
    <?php get_template_part( ‘nav’, ‘below’ ); ?>
    </section>
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    Thanks,

    Oliver

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Hi,

    Please use “Auto” and then try to change DOM position according to your div/span/p etc. based selectors.

    Thanks,
    Fahad

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Hi,

    I have given an option to
    “Hide/Show pagination if only one post available?” in version 1.3.0. It is just for testing purpose. Please check it that how does it facilitate you? Then i will push it as latest version.

    Thanks,
    Fahad

    Hi Fahad,

    Thank you very much for that.

    That serves my purposes very well.

    Thanks,

    Oliver

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    Great!

    Keep giving your reviews so it will help me to improve this plugin more.

    Thanks,
    Fahad

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not working when only one result’ is closed to new replies.