Support » Plugin: MailPoet - emails and newsletters in WordPress » Not working , when considered ready

  • Resolved selindmarkl

    (@selindmarkl)


    Seems to be a bad process for releasing new products.

    MailPoet-fel: Exception: You do not have permission to activate/deactivate MailPoet plugin. in /hsphere/local/home/jidoka/kiube.se/wp-content/plugins/mailpoet/lib/Config/Initializer.php:130
    Stack trace:
    #0 /hsphere/local/home/jidoka/kiube.se/wp-content/plugins/mailpoet/lib/Config/Initializer.php(97): MailPoet\Config\Initializer->maybeDbUpdate()
    #1 /hsphere/local/home/jidoka/kiube.se/wp-includes/class-wp-hook.php(298): MailPoet\Config\Initializer->onInit(”)
    #2 /hsphere/local/home/jidoka/kiube.se/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array)
    #3 /hsphere/local/home/jidoka/kiube.se/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #4 /hsphere/local/home/jidoka/kiube.se/wp-settings.php(448): do_action(‘init’)
    #5 /hsphere/local/home/jidoka/kiube.se/wp-config.php(110): require_once(‘/hsphere/local/…’)
    #6 /hsphere/local/home/jidoka/kiube.se/wp-load.php(37): require_once(‘/hsphere/local/…’)
    #7 /hsphere/local/home/jidoka/kiube.se/wp-admin/admin.php(31): require_once(‘/hsphere/local/…’)
    #8 /hsphere/local/home/jidoka/kiube.se/wp-admin/my-sites.php(10): require_once(‘/hsphere/local/…’)
    #9 {main}

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    Are you using the latest version? Are you logged in as an administrator?

    MailPoet Team.

    From the stack trace it looks like you’re running it under a Multisite. In the FAQ they mention that running under Multisite “works but isn’t supported.”

    You may have found one of the untested and unsupported aspects of the plugin.

    To @wysija, perhaps you can detect when running under Multisite and add an admin notice/disclaimed until you’re ready.

    To @selindmarkl, more detail on how to recreate the error may help their developers.

    @deltafactory thanks for pointing that out.

    @selindmarkl we released a fix for that on version: 3.0.0-rc.2.0.1

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not working , when considered ready’ is closed to new replies.