Support » Plugins and Hacks » [Resolved] Not working, Sorry Sorry. No data so far

[Resolved] Not working, Sorry Sorry. No data so far

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Hector Cabrera


    Hi there,

    I’m getting “Sorry. No data so far”. What’s up with that?
    There are a number of reasons that might explain why you are seeing this message: no one has seen or commented on your posts/pages since WordPress Popular Posts activation, you should give it some time; your current theme does not have the wp_head() tag in its <head> section, required by my plugin to keep track of what your visitors are viewing on your site; WordPress Popular Posts was unable to create the necessary DB tables to work, make sure your hosting has granted you permission to create / update / modify tables in the database.

    Did you check these already?

    Also, you might want to check this thread for a couple of suggestions.

    I have wp_head() and also I have the permission in the database.. here

    I tried to change the value of the post type from my custom post type to ‘page’ and it works. Only the custom post type and post are not working.

    Plugin Author Hector Cabrera


    All these post IDs belong to pages only?

    Yes, all of those post IDs are belong to pages only.

    Plugin Author Hector Cabrera


    Weird. Just tested on my development blog using the exact same settings you posted earlier and it works for me just fine:


    The same happens if I change post type to post or page.


    # Disable all other plugins and see if the problem persist. Specially if you’re using a caching plugin.

    # Switch to another theme for a second and check again (WordPress’ stock Twenty Twelve theme, for example).

    Plugin is great, but…
    Working on this page http://izbor-news.com/
    not working on identical page here: http://hop.hr/


    Sorry. No data so far.

    Hi hector,

    T’ve got the same problem as marky,

    I checked wp-head;
    I’ve got the db tables that are counting fine

    I’ve also tried changing theme and disabling some plug-ins
    but still…
    “no data so far”

    I have a multilanguage site with qtranslate,
    can there be a conflict with the language plug-in?
    (turning off qtrans-plug-in is quite complicated, so I’d rather avoid),


    by the way
    my site is

    Plugin Author Hector Cabrera


    Hi Frank,

    Just checked your site and everything seems to be in place. I also visited a couple of your entries none of them had any comments yet, so if you’re sorting your popular list by comments count then you get “Sorry, no data so far”. Is this your case?

    hi hector,

    I’m going by views,
    and I can see the number of views in the db (so it’s counting alright),
    What else can I check?

    thanks for your quick response,
    you really know what super-support is about!

    Plugin Author Hector Cabrera


    Well, are you on WordPress Multisite? Do you run any caching plugins?

    no chaching plugins,
    and it’s not multisite…

    Plugin Author Hector Cabrera


    Well, honestly I can’t think of any other reasons why it won’t work for you without further details:

    # WordPress version
    # Plugin version
    # Plugins installed
    # Current theme
    # Plugin configuration

    ok hector,
    i reinstalled the wpp plug and now it’s working,

    it should have been the first thing to try…

    I really appreciate your help_

    if you want I can send you translation for the language .po file in it (italian)
    so you can integrate in next release,

    Awesome plug-in–

    Plugin Author Hector Cabrera


    Since the OP has not replied in two weeks, I’m going to mark this as resolved.

    To the OP: if the problem persists, please feel free to mark it as unresolved again and post a comment again so I can notice the change.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Not working, Sorry Sorry. No data so far’ is closed to new replies.