Support » Plugin: Page Speed Optimization » not working properly

Viewing 4 replies - 1 through 4 (of 4 total)
  • also, under the proxy area i added those scripts(under “Capture external scripts and load the scripts through a caching proxy”):

    google-analytics.com/analytics.js
    facebook.net/en_US/sdk.js
    google.com/recaptcha/api.js
    static.hotjar.com/c/hotjar-268865.js
    static.doubleclick.net/instream/ad_status.js
    connect.facebook.net/he_IL/sdk.js
    connect.facebook.net/en_US/fbevents.js
    connect.facebook.net/signals/config/1522537124692627
    maps.googleapis.com/maps/api/js
    apis.google.com/js/platform.js
    script.crazyegg.com/pages/scripts/0024/8326.js

    but still it say i need to “Leverage browser caching” for this script:
    https://static.doubleclick.net/instream/ad_status.js (15 minutes)
    Hide details

    • This reply was modified 2 years, 3 months ago by roycegracie.
    Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Hi roycegracie,

    The ad_status.js script is initiated from an iframe and in specific www-embed-player.js:234. It could be a YouTube or similar video.

    To resolve the issue when the video is not visible in the Above The Fold display you could lazy load the video using the Lazy Load Scripts feature in the Javascript-tab. The example shows how to lazy load a Facebook widget. You could use the example code for iframes and YouTube videos as well.

    hello and thank you for your reply.
    i did the LAZY LOAD thing you suggested on the iframe of youtube in the homepage, but it didn’t work.

    do you happen to know what page this script is loading ?

    also, it seems strange to me that a script with “instream/ad_status.js” – INSTEGRAM. will be loaded inside a youtube or other video iframe, are you sure it is coming from an IFRAME ?

    also. i have found this script inside my theme:
    https://www.youtube.com/iframe_api

    i have moved the url :
    youtube.com/iframe_api

    under “Proxy Scripts” in the tab “proxy” tab. but this still dosn’t disable the google page speed error “Leverage browser caching”

    please any advice will be good

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘not working properly’ is closed to new replies.