Support » Plugin: CKEditor for WordPress » Not working on WordPress 4.0

Viewing 15 replies - 16 through 30 (of 63 total)
  • Same here:

    Errors:
    Uncaught TypeError: Cannot read property ‘top’ of undefined
    Uncaught TypeError: Cannot read property ‘hasClass’ of undefined (multiple)

    Plugin Contributor vokiel

    (@vokiel)

    The reason why CKEditor is not working with WordPress 4.0 (admin section only) is the editor-expand script.

    Quick tip to fix it is to add this code in your functions.php theme file:

    // Deregister editor-expand as it breaks CKEditor integration
    function custom_deregister_editor_expand() {
      wp_deregister_script('editor-expand');
    }
    add_action( 'admin_init', 'custom_deregister_editor_expand' );

    Oh dear . Me too. Knew I upgraded too early!

    Vokiel:

    You are my hero! Your quick fix worked! I am back and running with Ckeditor.

    Thanks so much.

    Vokiel´s solution not worked for me.
    I´m the only one?

    Unfortunately for me that tip did not work. I pasted the code in functions.php, I removed the cache files, deactivated and activated the plugin and nothing.

    Charles Dibartolo

    (@charlesbetterbizworkscom)

    I will give it a try
    Thanks

    Charles Dibartolo

    (@charlesbetterbizworkscom)

    That code works great. Thanks

    Plugin Contributor vokiel

    (@vokiel)

    @diego_circo @romarcio
    You can also try to unset autoresize on time_mce_before_init filter with this snippet:

    function custom_unset_autoresize_on( $init ) {
      unset( $init['wp_autoresize_on'] );
      return $init;
    }
    add_filter( 'tiny_mce_before_init', 'custom_unset_autoresize_on' );

    Some other errors may occur because of other plugins. Try to investigate which script throws error by blocking WP from concatenate scripts.
    Add this to your wp-config.php file:

    define('CONCATENATE_SCRIPTS', false);

    Then check JavaScript console errors.

    @vokiel
    Thanks! After looking for the solution, the first one was ok!
    Thanks!

    Thanks @vokiel, your last tip is working well.
    I checked the JavaScript console and no error is appearing.

    vokiel

    fufou certinho, funcionando perfeitamente. Valeu.

    Hi,

    When adding your code:

    // Deregister editor-expand as it breaks CKEditor integration
    function custom_deregister_editor_expand() {
    wp_deregister_script(‘editor-expand’);
    }
    add_action( ‘admin_init’, ‘custom_deregister_editor_expand’ );

    to the theme’s function.php my entire site doesn’t load. Main screen is all blank.

    I just paste your exact code in the bottom of the file. Please help.

    Hi

    I have implemented all suggestions by vokiel. None of them helps. Please tell another solution. It’s urgent.

    ulrichchr – You want to paste vokiel’s code before the closing php tag, not at the very bottom.

Viewing 15 replies - 16 through 30 (of 63 total)
  • The topic ‘Not working on WordPress 4.0’ is closed to new replies.