Support » Plugin: WP Mail SMTP by WPForms » Not Working On This Site I’m Working On (v1.4.1)

  • Resolved corporateslave

    (@corporateslave)


    I’ve installed the plugin and followed the documentation for Gmail. Everything went smoothly as the docs written… until the part where I need to click “Allow plugin to send emails using your Google account”.

    I always get Error400 during this process, so I decided to check the button’s href and found out that the client_id parameter is actually missing!

    https://accounts.google.com/o/oauth2/auth?response_type=code&redirect_uri=http%3A%2F%2Fexample.com%2Fwp-admin%2Foptions-general.php%3Fpage%3Dwp-mail-smtp%26tab%3Dauth&client_id=&scope=https%3A%2F%2Fmail.google.com%2F&access_type=offline&approval_prompt=force&include_granted_scopes=true
    (I’ve changed my domain name with a dummy one here just in case)

    So I tried cheating my way by editing the href and inserted my client_id and then clicking the button like normal.

    Get warned for unverified-whatever which I choose to ignore. And then presented with the ultimate decision of “Cancel” vs “Allow”. It was a tough decision.

    After clicking “Allow”, I got redirected to the plugin’s settings page. But no Success Message (as described in the docs) were witnessed at this point, and the “Allow plugin to send emails using your Google account” doesn’t exist… nor anything else beyond it (save button, ‘please support us’ box, etc).

    Similar situation also occurred in “Email Test” tab. Only 2 rows get rendered in this page: “Send To” and “HTML”, which is definitely not enough since the “Send Email” button is absent.


    Error message “Fatal error: Call to undefined method Google_Client::fetchAccessTokenWithAuthCode() in /home/exampledotcom/public_html/wp-content/plugins/wp-mail-smtp/src/Providers/Gmail/Auth.php on line 102” appeared when I used debug mode, not sure how to fix it.

    The “Misc” tab worked as usual though…

    This problem persist even after removing and reinstalling the plugin… unless I checked the “…remove ALL WP Mail SMTP data upon plugin deletion…” option.

    Tried redoing it 3 times (all with similar results) before I gave up and decided to ask for support here.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    @corporateslave

    Ok, it will be a tough one to figure out.

    It seems you have a compatibility issue with some OTHER plugin that has a dependency of some old Google library version.
    Can you please provide a list of activated plugins? Just names and versions, please. You can go to Plugins > Active filter page and copy everything in the table (you don’t have to clean up from descriptions/authors if you don’t want to).

    Wow… I must have been quite trashed last night to have missed such basic step in troubleshooting a WP site…

    Checked myself to see which plugin is causing the problem. Turns out this “Duplicator Pro” plugin was the culprit all along. I never used the plugin myself so I’m not sure how it works.

    Anyway… it’s case closed for now.
    Hope things went smoothly from here on.

    **changing status to resolved**

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.