Forums » Plugin: Easy Table of Contents » Not working on some pages

Viewing 10 replies - 1 through 10 (of 10 total)
  • ande1352

    (@ande1352)

    I’m having the same issue. On some pages the table of contents doesn’t appear, and then on others it does. The ones where it doesn’t there is no override set or anything. If i change to “TOP” as Souvik mentions, it DOES appear. Before first heading, it does NOT.

    UPDATE: I found that on the page I was looking at where it wasn’t working there was an ampersand “&” in one of the H2 titles. I removed that and replaced it with the word “and”, and for whatever reason that fixed the problem for me. So I’m wondering if certain symbols cause the TOC to not be rendered.

    • This reply was modified 4 years ago by ande1352.
    Steven

    (@shazahm1hotmailcom)

    @rswebsols

    Please update to the latest version. Does the issue persist?

    zodianz

    (@zodianz)

    I just downloaded this plugin and I was receiving the same issue. Like ande1352 said, I removed the & and it started working. Just wanted to share that that could be an issue with some of the TOC’s not showing up on certain pages. Not sure if this will be fixed in the future.

    Steven

    (@shazahm1hotmailcom)

    @zodianz

    Please open you own support topic. Alos, please links to affected pages and some exact samples of heading causing issue. So far I have not been able to duplicate the issue.

    zodianz

    (@zodianz)

    @shazahm1hotmailcom I apologize, I didn’t feel the need to open a support topic of my own since it was already listed. It wasn’t that big of an issue for me, just wanted to add that there was a solution for others just in case they were experiencing a similar issue, but if you’d like me to open a support ticket then I will 🙂

    Thank you for responding so quickly.

    Steven

    (@shazahm1hotmailcom)

    @zodianz

    Yes, please do, your issue is different from the original post. ande1352 should have open their own support topic too.

    Any way, having a new issue open with links to affected pages and samples will help since I cannot duplicate the issue myself. And, if I can not duplicate it then it can not be fixed.

    Thread Starter rswebsols

    (@rswebsols)

    @shazahm1hotmailcom

    Yes, I have updated to the latest version and tested again. The issue is still present.

    In fact, I have tested all 4 options. It is working for the options “Position: Top” and “Position: Bottom”. But it is not working for the options “Position: Before first heading” and “Position: After first heading”.

    The issue is only coming on those pages where I have content (including headings) that is generated from a shortcode.

    Steven

    (@shazahm1hotmailcom)

    @rswebsols

    Its possible the that the API provides the headings encoded in a way that does not conform to how WP handles encoding so when ezTOC searching thru the page content to insert the in-page anchors it can not find the headers because ezTOC is looking for headings encoded in one format but actually exist in a different one.

    It easy to create the TOC itself, its anything trying to find the matching headings and insert the in-page links. This would also explain why inserting top and bottom work while before/after the first heading do not.

    If I were to guess, looking at the page link you provided as not working … I but it is the trailing ellipses. I bet there are ... in the heading supplied by the API but ezTOC is looking for the encoded version of ellipses.

    Is there a way you can trim that trailing ellipses in the heading?

    Thread Starter rswebsols

    (@rswebsols)

    @shazahm1hotmailcom

    Yes, you are right. The issue was for the .... I have changed the ... with its respective HTML code … and now it is working.

    Thank you for your help.

    • This reply was modified 4 years ago by rswebsols.
    Steven

    (@shazahm1hotmailcom)

    @rswebsols

    Great to hear!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not working on some pages’ is closed to new replies.