Support » Plugin: WordPress ReCaptcha Integration » Not working on one site

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author podpirate

    (@podpirate)

    Whoa, that’s an interseting one!

    There is a JS TypeError in the script that searches the form for submit elements. For some reason it tries the call the getAttribute method of a method of a HTMLCollection, which results in a type error. The strange thing is, that it works everywhere else.

    I will come up with a fix in the next version. For now unchecking “Disable Submit Button” in the plugin settings should bring it back to work.
    Thanks for reporting!
    joern

    I did not think of trying to uncheck that! Yes now it works, thank you! No problem I hope the report helps :).

    Yes it works on all my other sites with that setting so VERY strange…could be theme related?

    I installed the update…..looks like the submit button disables properly but the captcha is still not shown…..hmmm….starting to think it’s a theme issue now on this site, but that would be odd…

    Plugin Author podpirate

    (@podpirate)

    Dangit, there’s I still a JS error.
    Would you mind to change line 279 in file wp-recaptcha-integration.php to

    for ( var s=0;s<self.submits.length;s++ ) {

    instead of

    for ( var s in self.submits ) {

    self.submits is an array, and should be iterable through for..in. Possibly there is some JS Library kidding around with the array prototype.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working on one site’ is closed to new replies.