Support » Plugin: GamiPress - BuddyBoss integration » Not working on mulitsite

  • Resolved jakobde

    (@jakobde)


    Hi,

    I followed your instruction on https://gamipress.com/docs/advanced/multisite/
    and installed all gamipress addons on the network the buddyboss platform and theme is installed on a second site. Any idea what could be wrong?

    However i get the following error on the main site:

    : Uncaught Error: Call to undefined function bp_get_member_types() in /home/ko/wp-content/plugins/gamipress-buddyboss-integration/includes/community/includes/requirements.php:44 Stack trace: #0 /home/ko/wp-includes/class-wp-hook.php(287): gamipress_bp_requirement_ui_fields(9967, ‘9966’) #1 /home/ko/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #2 /home/ko/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /home/ko/wp-content/plugins/gamipress/includes/admin/meta-boxes/requirements-ui.php(440): do_action(‘gamipress_requi…’, 9967, ‘9966’) #4 /home/ko/wp-content/plugins/gamipress/includes/admin/meta-boxes/requirements-ui.php(136): gamipress_requirement_ui_html(9967, ‘9966’) #5 /home/ko/wp-admin/includes/template.php(1389): gamipress_requirements_ui_meta_box(Object(WP_Post), Array) #6 /home/ko in /home/ko/wp-content/plugins/gamipress-buddyboss-integration/includes/community/includes/requirements.php on line 44

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @jakobde!

    Nice to talk to you today!

    Yeah, we have to fix that. You will get an updated notice asap!

    Thanks so much for reporting.

    Hope it helps!

    phoenixaerial

    (@phoenixaerial)

    I was trying to troubleshoot…and then I just found this topic. Hope you will fix it soon (I’m not able to show point or whatever rank achievement on BuddyBoss profile).
    Thank you

    Flavia Bernardez

    (@flabernardez)

    Hi @phoenixaerial

    This ticket issue was fixed one week ago.

    About your doubt, maybe you do not have configured the settings for showing GamiPress content on the profile’s tab. So that you can go to GamiPress > Settings > Add-ons and on BuddyBoss metabox, please activate GamiPress tabs to show earnings.

    Hope it helps!

    phoenixaerial

    (@phoenixaerial)

    Hi @flabernardez.
    It doesn’t work for me. Should the buddyboss integration plugin be network or single subsite activated? If I activate both gamipress and addon only for subsite, it works and I can see points on user profile. Network activating both plugins it never shown points on user profile.

    phoenixaerial

    (@phoenixaerial)

    Hi @flabernardez
    I got the issue: buddyboss integration plugin must be activated for every needed subsite, not network activated. This way it works. There must be some issue with buddyboss platform itself (their customer support wrote me it’s not fully multi site compatible).
    Problem solved

    Flavia Bernardez

    (@flabernardez)

    Hi again @phoenixaerial

    When I tried to activate the multisite network for BuddyBoss, it only appears on the main site, even having the “search across sites” activating. My BuddyBoss section on WordPress Dashboard from a Subsite is empty. So… maybe there is a BuddyBoss issue… so sorry.

    Please contact with BuddyBoss about it.

    Hope it helps!

    Flavia Bernardez

    (@flabernardez)

    Oh! Amazing! I’ve just see your new reply now. Okkk, thanks so much for reporting it 😄

    Have a great week!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not working on mulitsite’ is closed to new replies.