Support » Plugin: jQuery Pin It Button for Images » Not working on featured images

  • Resolved zackrohn

    (@zackrohn)


    I’m having trouble displaying the button on the portfolio here. I’ve tried the solution listed at https://wordpress.org/support/topic/not-showing-on-featured-images-2/ (apologies for replying to this thread instead of starting a new one originally) and this did not work. I’ve searched the theme to see if something may be preventing this and have not had luck in finding that so far. Any tips would be much appreciated, Thanks!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @zackrohn,

    From what I can see, you’ve disabled the plugin. If you’re still interested in solving the issue, please activate it and let me know. If not, also let me know, so I can close this thread.

    Thread Starter zackrohn

    (@zackrohn)

    Hi @mrsztuczkens thanks for responding. the plugin is active and still very interested in solving the issue. Not sure why it would appear to be disabled. There were some images the plugin was appearing on that I did not want that I turned off though settings, maybe something is going wrong there?

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @zackrohn,

    the plugin’s code is basically nowhere to be seen on the website. For starters, please change the Show on setting to the default value:

    [front],[home],[single],[page],[archive],[search],[category]

    and clear the Disable on setting and let me know once that’s done. That should at least make it active and we will go from there.

    Thread Starter zackrohn

    (@zackrohn)

    Thanks @mrsztuczkens! I just did as requested. As you will see, the button is now visible on the home page and about me, but not the fiber art or tapestry pages (where I’d like it).

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @zackrohn,

    so your theme is adding a pseudo element that prevents the image from being hovered (and why when you right-click the image, you can’t download it right away). To fix that, try adding the following CSS:

    .featured-image > a:first-of-type:before {
      content: none !important;
    }

    That should do the trick. Let me know if that helped.

    Thread Starter zackrohn

    (@zackrohn)

    Yep that did it! thanks so much for your great help, really appreciate it!

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Happy to help! Marking the topic as resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not working on featured images’ is closed to new replies.