Support » Plugin: Freesoul Deactivate Plugins » Not working on custom WooCommerce URLs?

  • Resolved Iworldc

    (@iworldc)


    Hello Jose,

    I just discovered that on WooCOmmerce product pages, disabling plugins does not work.
    I added a custom URL to a product page, disabled several plugins, but they’re still active. Even when I disable WooCommerce, the product just appears.

    Am I doing something wrong?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jose

    (@giuse)

    Hi @iworldc Thank you for your thread.

    Do you have a server cache active?

    Please try to check a product page after clicking on the “eye” icon you find going with your mouse on the row of the “Singles” settings page.

    The page will open on a new tab. Go on that page, inspect elements and go to “Console”.
    You will see the list of disabled plugins.

    You can see that list only if you load the page from the eye icon, you can’t see it if you visit the page in another way.

    Another way to see the list of disabled plugins in the console is adding this line in your wp-config.php:

    define( 'EOS_DP_DEBUG',true );

    adding that line you don’t need to use the “eye” icon.

    First of all, be sure your product page is not served by the cache.

    Plugin Author Jose

    (@giuse)

    Hi @iworldc.

    if your product is reachable at https://your-site.com/product/product-example/
    Try to use this in the custom URLs for your products:

    */product/* to get all products

    */product/product-example/ to get the specific product, in this case, called product-example.

    Tell me if this works. If it works, it means it’s a bug that I will solve in the future version. Until then you can use that method.

    mikemynis

    (@mikemynis)

    Hi Jose,

    Thank you for responding so quickly.

    I use a caching plugin in WP. I flushed the cache several times.
    Do I need to disable the caching?

    But does that mean that I can never use caching in combination with your plugin?

    When I check the ‘Singles’ settings page, I don’t see the individual product pages. I only see regulare pages.

    When I select one such page and click the eye icon, the URL opens. When i hit F12 (Chrome) and check the console, I see that no plugins are disabled.

    Please see this screenshot

    My url structure is https://www.example.com/category/productname/

    Any idea?

    mikemynis

    (@mikemynis)

    By the way, this is my private account that I use now, since my iWorldc account comments are hold for moderation. I guess I commented too quickly several times, and the wordpress.org system might have thought that I was spamming, which was not the case, of course.

    Mike

    Plugin Author Jose

    (@giuse)

    Of course, you can use Freesoul Deactivate Plugins in combination with cache plugins.
    I suggest you use cache plugins.

    I said to be sure the page was not served by the cache for the problem-solving.

    Imagine this case: you don’t disable any plugins, then you visit the page, the cache is built without disabling plugins, then you disable the plugins.
    For popular cache plugins, Freesoul Deactivate Plugins will clear the cache of that page, but if it’s not a popular cache plugin, it may happen that you build the cache before disabling the plugins.

    So, now we are sure it’s not a cache problem.

    You should find the products in the submenu of Singles.
    In singles, you have a submenu with all custom post types that are publicly queriable, and it should include also the products.
    Please refresh the settings page and tell me if you don’t see your custom post types in the submenu of “Singles”.

    It will be easier for you to decide what plugins should be active with the settings under singles.
    You have also the settings “Post Types” if you want to disable always the same plugins for the products.

    Clicking on the “Help” tab you see the flowchart that shows how the plugins are disabled according to the options (Post Types, Singles, Custom URLs, Mobile, Search).

    If you still want to use the custom URLs, try this:

    */category/productname/ for the product “productname”

    */category/* for all products of category

    It should work also writing the full URL, but if you confirm that writing what written above it works, I will check and solve this issue for the next release.

    If it doesn’t work in any case, I will ask you more details.

    mikemynis

    (@mikemynis)

    Hi, When I check ‘Singles, it gives me 1 submenu item: ‘PAGINA’S’. (= pages)

    Below that, there’s one item: ‘RELEVANT PAGES’.

    So indeed I don’t see custom post types and I don’t see products.

    In ‘POST TYPES’, I also see ‘Pagina’s’ as the only post type. Nothing more.

    I tried ‘*/category/productname/’, but as I mentioned earlier, that doesn’t do anything.

    Could it be that

    • somehow we’re running into a timeout? I have > 1500 products and each product has up to 4 variations.
    • I’m using a plugin called ‘Custom Permalinks’ (https://www.custompermalinks.com/). That this somehow makes that the URL is not recognized?
    • This reply was modified 9 months ago by mikemynis.
    • This reply was modified 9 months ago by mikemynis.
    Plugin Author Jose

    (@giuse)

    Hi @mikemynis
    thank you for the information.
    As written in the plugin description: “Only the permalinks structures “Day and name”, “Month and name”, “Post name” and the custom ones ending with “%postname%” are supported for permanently deactivating plugins (they are also better for SEO).

    The same as above if you are using plugins to change the permalinks, as, e.g., Permalink Manager Lite.”

    Probably you don’t see the custom post types in the “Singles” submenu because of Custom Permalinks.

    The URL is important to get the right post or page. When you have a plugin that modifies the permalink structure, you may have issues.

    Are you using the free version of Custom Permalinks?

    In any case, I will perform some tests after installing the free version of Custom Permalinks and I will check.

    mikemynis

    (@mikemynis)

    Aha, so that me the source of the problem in my case.
    I am using the free version of ‘Custom Permalinks’

    Plugin Author Jose

    (@giuse)

    Hi @mikemynis.

    I have checked with Custom Permalinks. I see all the custom post types also if Custom Permalinks is active. I think the problem is caused by something else.

    Try to disable Freesoul Deactivate Plugins and then activate it again. This will force the update of the Freesoul Deactivate Plugins cache where the list of custom post types is saved. This cache is updated every time you activate a new plugin, and when you save the options after activating Freesoul Deactivate Plugins for the first time.

    I would do the following:
    – disable Freesoul Deactivate Plugins (only disabling, not delete it)
    – activate again Freesoul Deactivate Plugins
    – check if you see the custom post types in the Freesoul Deactivate Plugins Settings
    – save the post types settings
    – check if you still see the custom post types in the Freesoul Deactivate Plugins Settings after refreshing the page
    – disable one of your plugins
    – check if you still see the custom post types in the Freesoul Deactivate Plugins Settings after refreshing the page
    – enable the plugin you have disabled
    – check if you still see the custom post types in the Freesoul Deactivate Plugins Settings after refreshing the page

    If it doesn’t work, I would like to have the list of your plugins. I’m afraid one of your plugins is having a conflict with FDP.

    To quickly get the list of your active plugins, go to the plugins page, inspect elements, go to the console, paste the following code and press enter:

    var plugins = '';jQuery('.wp-list-table.plugins .active .plugin-title strong').each(function(){plugins += jQuery(this).text() + ';';});console.log(plugins);

    I would prefer to have the list as a text than a screenshot if possible.

    mikemynis

    (@mikemynis)

    Good morning Jose,

    Aha, I disabled and then re-enabled the plugin and now I do see all products and custom post types. The whole list is now much, much longer.

    I see all products too! That is a good sign.

    I took a product, disabled some plugins, saved the settings, clicked the eye-icon and checked the console. Hurray! I now see a list of disabled plugins.

    So after all it just works! I only needed to disable and re-enable the plugin!

    Thank you again for your outstanding help, Jose!

    Plugin Author Jose

    (@giuse)

    Hi @mikemynis

    Perfect. Thank you for the information.
    In any case, something strange happened with the internal cache. I will check and be sure that it will be not possible anymore to have this kind of situation.

    You are welcome. Thanks to you for discovering this issue.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Not working on custom WooCommerce URLs?’ is closed to new replies.