Support » Plugin: Genesis Custom Headers » Not working on custom post types and Woocommerce

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Nick Diego

    (@ndiego)

    Hello dsgnr,

    I honestly have not tested this plugin thoroughly with Woocommerce so I will look into that, but I am curious about your issues with custom post types. Can you provide me with a little more information about how these custom post types are generated (i.e. through a theme or other plugin)? From there, we should be able to resolve the issue.

    Thanks,
    Nick

    dsgnr

    (@designsbytouch)

    Hello, I am using the genesis custom post types plugin with this.

    Custom headers seem to work on individual Woocommerce products, but not the main “Shop” page.

    With my custom post type, again this works on the individual items but not the main archive page.

    Thanks

    Plugin Author Nick Diego

    (@ndiego)

    Oh ok, now I understand. In the current version of this plugin, it does not support custom headers on archive pages, 404 pages, search pages, etc (the Shop page is basically an archive page for products). It only works on the individual pages, posts, and custom posts.

    That said, this is something I have been toying around with and am working on an “elegant” way to work this feature into the plugin. I need to build all the archive settings into the main plugin settings page which gets clunky very quickly depending on the number of custom post types you have. I have no timeline for this, but promise I am working on it.

    Sorry I do not have an immediate solution for you….

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not working on custom post types and Woocommerce’ is closed to new replies.