Support » Plugin: WP fail2ban - Advanced Security Plugin » Not working on CentOS 6.x

  • Resolved simonmatthews

    (@simonmatthews)


    CentOS 6.x has Php 5.3, which the Readme file tells me is supported, but I get the following error:
    PHP Parse error: syntax error, unexpected ‘[‘ in /home/httpd/html/fail2ban-keep/wp-fail2ban.php on line 48

    Note that there are other errors if this error is fixed.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author invisnet

    (@invisnet)

    You’re right, currently 5.3 support is broken. Version 4.2.5 will fix that – should be released later today.

    I’ll put a sticky post up too, but FYI: support for PHP 5.3 will stop at the end of the year. It takes a disproportionate amount of time and work to support – with CentOS 6 support ending in November I hope that’ll be the end of it.

    Plugin Author invisnet

    (@invisnet)

    I released 4.2.5 yesterday – could you give that a try and let me know how you get on?

    Thread Starter simonmatthews

    (@simonmatthews)

    I installed it. It doesn’t break the website, which is good!

    I’ll keep an eye on the logs to see if it logs anything.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not working on CentOS 6.x’ is closed to new replies.