WordPress.org

Forums

Sticky Element
[resolved] Not working on category pages (8 posts)

  1. sscalifornia
    Member
    Posted 1 year ago #

    I really like this plugin. I'm having an issue with it not working on a category page. It seems to work everywhere else but as soon as I check an archive page of categories it stops working. Any help is appreciated.

    By the way, I noticed that the plugin get jumpy if the div you target has padding or margin on the top. Maybe that's something that can be fixed in the future. Thanks again for the plugin.

    http://wordpress.org/plugins/sticky-element/

  2. Youdaman
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the feedback! If you can paste a link to the page I can take a look and see if I can help.

  3. sscalifornia
    Member
    Posted 1 year ago #

    Thanks for replying. You can see my issue on this page.

  4. sscalifornia
    Member
    Posted 1 year ago #

    This page is actually the category page. I can see the plugin is not kicking in on firebug when I get to the sticky element. Every other page I see some inline styles start to happen when I scroll.

    It's also not working on single post pages and the author page which I linked to on my last comment. Thanks again for any assistance.

  5. Youdaman
    Member
    Plugin Author

    Posted 1 year ago #

    I just had a look at those pages but I'm not sure which element you're wanting to be sticky? Could you please indicate its class or id please.

  6. sscalifornia
    Member
    Posted 1 year ago #

    Sorry about that. The sidebar becomes sticky. I'm targeting the class .sidebar_wrap. Thanks.

  7. Youdaman
    Member
    Plugin Author

    Posted 1 year ago #

    I just looked in the console:

    `".blackbar" element not found, please check Sticky Element plugin settings '

    I viewed source and indeed there was no element with class="blackbar".

    Perhaps try .footer as the end element? Let me know how you go.

  8. sscalifornia
    Member
    Posted 1 year ago #

    Nice catch. That helped me in two ways because I didn't know the blackbar element wasn't on those pages. Thanks that solved my issue. I really appreciate it and I think your plugin is great.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Sticky Element
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.