WordPress.org

Support

Support » Plugins and Hacks » Not working need help

Not working need help

  • testeree

    @testeree

    after installation i put this

    [Register role=”subscriber” password=”yes”] into a page and get that error code

    Warning: require_once(__DIR__/lib/sreg.class.php) [function.require-once]: failed to open stream: No such file or directory in /homepages/12/d25539295/htdocs/cms/wp_intern/wp-content/plugins/simplr-registration-form/simplr_form_functions.php on line 439

    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/lib/sreg.class.php’ (include_path=’.:/usr/lib/php5′) in /homepages/12/d25539295/htdocs/cms/wp_intern/wp-content/plugins/simplr-registration-form/simplr_form_functions.php on line 439

    Thx for your help!

    http://wordpress.org/plugins/simplr-registration-form/

Viewing 12 replies - 1 through 12 (of 12 total)
  • duncankills

    @duncankills

    exact same with me

    pazifikwelle

    @pazifikwelle

    exact same with me

    aartikhairnar

    @aartikhairnar

    please give the solution asap..!!!

    vaneedenhenry

    @vaneedenhenry

    exact same with me

    xpafiolis

    @xpafiolis

    +1 need file! pLEASE send file!

    I have the identical issue too. It may be worth adding that we are using a multi-site install.

    For a quick fix, replace the sreg_basic function on line 438, with the following function.

    function sreg_basic($atts) {
    	//Check if the user is logged in, if so he doesn't need the registration page
    	if ( is_user_logged_in() AND !current_user_can('administrator') ) {
    		global $user_ID;
    		$first_visit = get_user_meta($user_ID, 'first_visit',true);
    		if(empty($first_visit)) {
    			$message = !empty($atts['message'])?$atts['message']:"Thank you for registering.";
    			update_user_meta($user_ID,'first_visit',date('Y-m-d'));
    			echo '<div id="message" class="success"><p>'.$message.'</p></div>';
    		} else {
    			echo "You are already registered for this site!!!";
    		}
    	} else {
    		//Then check to see whether a form has been submitted, if so, I deal with it.
    		global $sreg;
    		if(isset($sreg->success)) {
    			return $sreg->output;
    		} else {
    			if(is_array($sreg->errors)) {
    	        $out = '';
    	        foreach($sreg->errors as $mes) {
    	            $out .= '<div class="simplr-message error">'.$mes .'</div>';
    	        }
    	    } elseif(is_string($sreg->errors)) {
    	        $out = '<div class="simplr-message error">'.$message .'</div>';
    	    }
    	    return $out.simplr_build_form($_POST,$atts);
    		}
    
    	} //Close LOGIN Conditional
    
    } //END FUNCTION

    Wow jjborja !

    It worked Wonderful for me Thank you so much

    It worked as a charm, thank you very much.

    Is there any explanation about why did the plugin crashed?

    It worked form me as well! Thank you so much!

    @jjborja
    I see you’re a freelancer, can I get your contact info or do you have a site?

    esmi

    @esmi

    Forum Moderator

    Please try http://directory.codepoet.com/ or http://jobs.wordpress.net/

    This topic has now been closed as per the Forum Rules

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not working need help’ is closed to new replies.