Support » Plugin: WP OAuth Server (OAuth Authentication) » Need update for WP 5.2?

Viewing 2 replies - 1 through 2 (of 2 total)
  • php error check shows this as well:
    FILE: ………public_html/wp-content/plugins/oauth2-provider/library/WPOAuth2/Request.php
    ————————————————————————————————————————————
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————————————
    101 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0; Use php://input instead
    104 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0; Use php://input instead
    109 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0; Use php://input instead
    112 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0; Use php://input instead

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Thanks for the feedback. We will be releasing an update for 5.2 shortly. With this said, the errors you are getting back from the PHP check are false positives. Those errors are picking up a backward compatibility function not used if an install is using a later PHP version.

    Thanks again for your time and posting here!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Need update for WP 5.2?’ is closed to new replies.