Support » Plugin: postTabs » Not Working in WordPress 3.5

Viewing 8 replies - 1 through 8 (of 8 total)
  • Just found out the problem…Under the Links Behavior, the Single Post or Page has to be set to Hide-Show Tabs. This makes the tabs work on the website, but I really need to be able to go directly to a tab and can’t without the Permalinks setting.

    Any help to fix would be greatly appreciated!

    Found the same.

    Deleting and reinstalling older version of plugin does not seem to help: Any ideas on whether some db change is made by the plugin that needs removing as well?

    On closer look, the plugin inserts a line like the following after the postTabs content has been added to the page, with the aim of hiding/revealing the appropriate tab content:
    <script type=’text/javascript’>jQuery(document).ready(function() { postTabs_show(1,445); });</script><script type=”text/javascript”>

    This is supposed to override the jQuery(document).ready(function() {*contents here*}); defined in the postTabs.js file. For some reason, this is no longer working in WP 3.5. The base defined jQuery(document).ready(function() {*contents here*}); is called instead which means the basic page view (1st tab?) is loaded rather than the specific tab that the user clicked on.

    Any js buffs out there able to help with a diagnostic?

    Just tried both settings (permalink and hide-show tabs) – both worked as intended. Have you tried disabling/enabling other plugins to make sure it’s not a conflict issue? How about the theme you’re currently using?

    I ask because I am having absolutely no problem with this plugin, and can’t recreate your issue on my installation.

    Not affiliated with this plugin, just trying to help.

    I did try disabling all of the other plugins but it still did not work. I use the Thesis theme and it has worked with GT Tabs up until this point. I will likely just find another plugin or another way to break up the content.

    Thanks for your help!

    Plugin Author Rodrigo Primo

    (@rodrigosprimo)

    The plugin seems to work perfectly for me as well running on a clean WordPress 3.5 install with both permalink and hide-show tabs.

    Let us know if you find out how we can reproduce the problem.

    Thanks for that. On further investigation, the problem looks likely to be a js incompatibility with the current WP theme! That’s definitely something I can sort out…

    Hi all,

    The conflict was with OpenHook 4.0.1. I tried to rollback to version 3.3.1 since that is what I have on my test site, but I still had issues. I decided to just eliminate OpenHook and use the custom_functions.php file instead.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not Working in WordPress 3.5’ is closed to new replies.