WordPress.org

Forums

WordPress PopUp
[resolved] Not working in SSL (new issue) (18 posts)

  1. iwpdev
    Member
    Posted 1 year ago #

    Hi,

    I saw the post from a month ago, where I changed the plugins/wordpress-popup/popoverincludes/includes/functions.php and overwrote with the code below, but I just get a blank page and my site doesn't show anything after I update the functions.php file. My site is currently password-protected so I can't send out a public URL. Thank you.

    function set_popover_url($base) {
    
    	global $popover_url;
    
    	if(defined('WPMU_PLUGIN_URL') && defined('WPMU_PLUGIN_DIR') && file_exists(WPMU_PLUGIN_DIR . '/' . basename($base))) {
    		$popover_url = trailingslashit(WPMU_PLUGIN_URL);
    	} elseif(plugins_url() && defined('WP_PLUGIN_DIR') && file_exists(WP_PLUGIN_DIR . '/'.PO_PLUGIN_DIR.'/' . basename($base))) {
    		$popover_url = trailingslashit(plugins_url() . '/'.PO_PLUGIN_DIR);
    	} else {
    		$popover_url = trailingslashit(plugins_url() . '/'.PO_PLUGIN_DIR);
    	}
    
    }

    https://wordpress.org/plugins/wordpress-popup/

  2. iwpdev
    Member
    Posted 1 year ago #

    Sorry, I should say that the current issue is that the popover does not recognize the "visit Not via an internal link" so it shows up on every page now. Thanks.

  3. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    Sorry to hear of the problems you are having.

    Sorry, I should say that the current issue is that the popover does not recognize the "visit Not via an internal link" so it shows up on every page now

    I have tested it on my test site using latest version of WordPress PopUp plugin, WordPress default theme Twenty Twelve and using "visit Not via an internal link" condition, it worked fine without any issues.

    You can just try on your development site deactivating all other plugins and using default WordPress theme like Twenty Twelve as displayed in the flowchart on the following page to know which theme/ plugin is conflicting if any.

    http://premium.wpmudev.org/manuals/getting-support/

    Kind Regards,

  4. iwpdev
    Member
    Posted 1 year ago #

    Thanks for the quick response. Everything was working fine until I added the SSL. Is your test site using SSL? Thanks.

  5. iwpdev
    Member
    Posted 1 year ago #

    Hi. So I tried deactivating all the plugins and it is still doing the same thing. Any Ideas? Thank you.

  6. Garrett Hunter
    Member
    Posted 1 year ago #

    I am also having a problem with this plugin over SSL.

    Test Scenario 1:
    1. Force SSL for wp-admin
    2. Go to Pop Overs settings "https://yourdomain.com/wp-admin/admin.php?page=popover"
    3. The up / down draggable image to the left of existing pop overs does not display

    Test Scenario 2:
    1. Click Add New (https://yourdomain.com/wp-admin/admin.php?page=popover&action=add)
    2. The Conditions that are supposed to be displayed together in a box on the right are displayed as text below the content area. See http://beta.whitepeacockyoga.com/images/popover-ssl-error.jpg

  7. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    I have tested it using SSL and could reproduce the same issue using "visit Not via an internal link" condition.

    To fix this issue just add the following code on line number 178 in the below WordPress PopUp plugin( version : 4.4.5.4 ) file overwriting existing code.

    Before Editing:

    case "internal":	$internal = str_replace('^http://','',get_option('home'));

    After Editing:

    case "internal":	$protocol = is_ssl() ? '^https://' : '^http://';
                    	$internal = str_replace($protocol,'',get_site_url());

    This issue will be fixed in the future version of plugin.

    Note: You are making changes in the core plugin file and it will be overwritten when you update the plugin so you have to make these changes again after updating the plugin.

    Cheers,

  8. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @Garrett Hunter,

    This is a known issue and this issue can be fixed using the solution posted in the following reply.

    http://wordpress.org/support/topic/does-not-work-in-ssl-https-pages?replies=4#post-5232572

    This issue will also be fixed in the future version of plugin.

    Cheers,

  9. iwpdev
    Member
    Posted 1 year ago #

    Hi. Thank you for getting back to me and offering up a solution but unfortunately it is not working. I am also using the WordPress HTTPS plugin, but I tried deactivating and it was still doing the same thing. The only way I am able to get this working right now is to also add the condition of "Popover shown less than 1 times". Any other ideas?

    Thank you.

  10. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    It's working fine for me after making these changes.

    You should add the previously provided code in the following WordPress PopUp plugin file.

    wordpress-popup\popoverincludes\classes\popoverajax.php

    Also make sure you have used the code provided in the following reply which you have posted in your initial reply.

    http://wordpress.org/support/topic/does-not-work-in-ssl-https-pages?replies=4#post-5232572

    Regards,

  11. iwpdev
    Member
    Posted 1 year ago #

    Hi. I double checked that I have everything updated but it is still not working for me. I even tried deactivating the HTTPS plugin (http://wordpress.org/plugins/wordpress-https/) and still no luck. Do you foresee any issues with the workaround I have of "Popover shown less than 1 times"? How long does the cookie stay in the user's system?

    Thanks again.

  12. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    It is working fine on my test site using SSL after making the above suggested changes.

    Which version of WordPress and WordPress PopUp plugin are you using?

    Please make sure to use latest one.

    There may be a theme / plugin conflict issue on your site. Please try using it on your development site deactivating all other plugins and using default WordPress theme like Twenty Twelve.

    Regards,

  13. iwpdev
    Member
    Posted 1 year ago #

    Hi. Unfortunately I have to use the theme and setup that I have. Is there a way to change the cookie to be a session cookie then? I am trying to find workarounds for what I am working with.

    Thank you.

  14. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    I am just asking you to temporary deactivate plugin and use default theme to know what is causing the issue.

    Is there a way to change the cookie to be a session cookie then?

    Why do you want to do this?

    You can change the plugin code or develop custom code to achieve whatever you want to.

    Regards,

  15. iwpdev
    Member
    Posted 1 year ago #

    Hi. Thanks again for getting back to me so quickly. Unfortunately the site went live yesterday and I don't have a staging environment with an SSL setup so I can't really test this. The reason I wanted to create a session cookie is so every time someone closes out the window/tab, the popup will show again. Unfortunately I am not a programmer so I am not entirely sure what to look for in the code. I did manage to change it so the cookie expires after 1/2 hour, but I wasn't sure if there was an easy way to just make it a session cookie. I looked to see if that was a feature in the premium version of the plugin, but I am not seeing that as an option otherwise I would have upgraded. So is there an easy way to let me know how to make it a session cookie or am I on my own for that one?

    Thank you.

  16. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    There isn't any way to change the cookie to be a session cookie other than modifying the plugin code.

    The reason I wanted to create a session cookie is so every time someone closes out the window/tab, the popup will show again.

    Do you mean if any body closes the pop up by clicking "Never see this message again" link then it should affect only for that user log in session and not others?

    To achieve this you can develop a custom code the similar way posted in the following reply.

    http://wordpress.org/support/topic/never-see-this-message-link-turns-off-all-popups?replies=7#post-5189499

    Cheers,

  17. iwpdev
    Member
    Posted 1 year ago #

    I currently have the "Never see this message again" disabled so they don't see that anyways. I am trying to accommodate the idea that this site could very well be used on public computers so I was trying to figure out a solution to address different people getting on the same computer. I will stick with what I have happening now and see if we get complaints about having to go through the popup too much. Part of pushing it is also to make sure we capture the information in the corm embedded in the popup. Thanks again for all your help and I will try it out on another site again I am sure. Cheers.

  18. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @iwpdev,

    I understood your requirements but as i have told you previously you will have to develop custom code to achieve it.

    Have a great day!

    Cheers,

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress PopUp
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.