• Resolved livecanvas

    (@dopewp)


    I got this “error” message while trying in my localhost environment.

    __(‘Top Menu’, ‘theme’),’footer-menu’ => __(‘Footer Menu’, ‘theme’))); add_image_size(‘smallest’, 400, 300, true); add_image_size(‘large’, 600, 400, true); add_image_size(‘largest’, 800, 600, true); add_image_size(‘huge’, 1200, 800, true); add_image_size(‘square’, 400, 400, true); ?>

    I wish to use this theme with the LiveCanvas BS4 builder. livecanvas.com

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author dadopuccio

    (@dadopuccio)

    Hi there,
    the code has been tested out in localhost situations as well, should work fine.

    As our Theme Creator for Bootstrap is a Plugin, not a Theme, first make sure it is installed into the right folder ‘/wp-content/plugins’.
    If everything went fine with the installation you should be able to see in your WordPress Dashbord the plugin, from there you can create your theme.

    If you think you installed the plugin correctly, in what situation do you get the display of that error?
    (It’s not actually an error, but a display of some lines of the code… That’s why I think that might be something wrong with the installation.)

    P.S.
    This plugin is designed to create themes for WordPress, similar to what LiveCanvas does, so I’m not sure it would be usefull to work with both.

    Let us know,
    Davide

    • This reply was modified 3 years, 9 months ago by dadopuccio.
    Thread Starter livecanvas

    (@dopewp)

    Hi Davide, my purpose was to test your BS theme creator with LC, since it can run on any Bootstrap themes, like UnderStrap https://livecanvas.com/faq/which-themes-with-livecanvas/
    Anyway, thanks for your clarification.

    We get that error once we’ve activated the BS theme. All unnecessary plugins are turned off.

    Plugin Author dadopuccio

    (@dadopuccio)

    Ok, I think we find out the problem.

    LiveCanvas requires the WP theme to have certain files as you can see here at number 3).
    The empty.php under the directory page-templates isn’t created in our Theme, as well as the function lc_theme_is_livecanvas_friendly(){} has to be added in functions.php file.

    If you follow those steps contained at the link, the BS theme created with our plugin should work perfectly fine with LC.

    The themes created with our plugin are very basic, we didn’t think of compatibility with LC in the project phase, with newer releases we could add this feature.

    Anyway, the problem is related only to compatibility with LC, not to localhost, we should change the topic’s title.

    Just to be sure, do you confirm the creation of the theme was ok? Just applying the new theme caused the issue?

    Thank you,
    Davide

    Thread Starter livecanvas

    (@dopewp)

    Maybe I’ve found the issue.
    I’ve changed the PHPtag at the beginning of the theme’s functions.php and now it seems to work.

    So the first line on this file should be:

    <?php
    instead of <?

    I’m testing with the latest version of WP and 7.4.2 php version.

    Plugin Author dadopuccio

    (@dadopuccio)

    Yes, you’re right, we’ll fix ASAP.

    Thank you.

    Plugin Author dadopuccio

    (@dadopuccio)

    The Plugin has been updated, the functions.php file has been fixed and also some other bugfixing. Update the plugin and try to create another theme.

    Should work fine now, let us know if there’s anything else that is not working.
    Thanks,
    Davide

    Plugin Author dadopuccio

    (@dadopuccio)

    Bug fixed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not working in localhost’ is closed to new replies.