Support » Plugin: WC Password Strength Settings » Not working in latest version of Woo

  • Resolved alex.devine

    (@alexdevine)


    Hi,

    Plug-in looks fantastic but it is not working in the latest version. It is still showing the default Woo commerce messages and not showing the custom messages from the plug-in.

    Please advise!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Danny Santoro

    (@danielsantoro)

    Automattic Happiness Engineer

    Hi Alex!

    I’ve just tested in WooCommerce version 3.0.4 and it still works for me.

    * These are my settings for the plugin: http://cld.wthms.co/yzFx
    * This is what appears if a user tries to log in: http://cld.wthms.co/Bn5A

    That’s using the Storefront theme which doesn’t have any template overrides or code that could conflict. What you may want to try is to temporarily switch to Storefront or a theme like Twenty Sixteen/Seventeen to see if that helps.

    Let me know if this works for you!

    Hi Danny,

    Thank you for your quick response, I did try using Twenty Seventeen without any luck. it still displays the default 🙁

    Screenshot:

    https://www.dropbox.com/s/cqz8i38roxjo8x7/Screen%20Shot%202017-04-24%20at%2021.34.43.png?dl=0

    Same here. Using 3.0.4 and WP 4.7.4 and disabled all plugins. Still only shows default Woo commerce messages and not showing the custom messages from the plug-in. Made sure cache was gone and tried in different browsers. So close…argh!

    UPDATE: Sorta fixed it. The Woocommerce default message always says “Hint: The password should be at least twelve characters long. To make it stronger, use upper and lower case letters, numbers, and symbols like ! ” ? $ % ^ & ).” not matter what minimum level I select with this plugin. (Would be nice to get rid of that).

    So I just changed the the custom message to say “Good enough password (ignore the message below).” on whatever level was the minimum I would allow. It still shows the Woocommerce message, but now they can just click REGISTER and be done. Hopefully the customer understands MY message and doesn’t abandon the cart out of frustration.

    • This reply was modified 2 years, 6 months ago by  Justacip.

    Thank you for jumping in @justacip 🙂

    Author, any update on this, please?

    I really would like to continue to use it.

    Regards,

    Plugin Author Danny Santoro

    (@danielsantoro)

    Automattic Happiness Engineer

    Sorry for the hold up, all! I’m looking into this and will report back ASAP – I’ve been away for a bit and am just catching up. Stay tuned. 🙂

    Plugin Author Danny Santoro

    (@danielsantoro)

    Automattic Happiness Engineer

    Ahh, I see what you mean – the plugin doesn’t change this text:

    Hint: The password should be at least twelve characters long. To make it stronger, use upper and lower case letters, numbers, and symbols like ! ” ? $ % ^ & ).

    You can see what it does by checking out the login page here: https://wpsantoro.mystagingwebsite.com/my-account/

    So the messages are working (Level 3 is what it’s set to) regarding the bolded text. I can look into changing the guide message there and have that be an editable field – it’s actually requested on the GitHub, so expect something soon.

    Hi Danny,

    I hope your time away was enjoyable 🙂

    It would be great to just display the text set in your plugin. There is no need to display the Woocommerce default text at all 🙂

    Look forward to the update.

    Regards,

    I’m having the same problem. WooCommerce 3.0.6, WP 4.7.4, all other plugins up to date. Trying to create an account either from the checkout page or the “My Account” page shows the default WooCommerce password hint even though I’ve set the plugin to allow any password (no restrictions). It does allow me to create an account with a 3-character password, but I think the WooCommerce instructions appearing and the “too weak” message would confuse a user.

    Currently I wouldn’t consider this plugin workable, I hope you can get it resolved real soon.

    I am also experiencing an issue like this. I set the strength to 4 and users are still allowed to create an account with a Weak or Short password. Nothing is being enforced.

    Plugin Author Danny Santoro

    (@danielsantoro)

    Automattic Happiness Engineer

    Hey JPmorris and pinksharpii – if you could, submit an email to help@viai.co which will open a ticket on my little help desk so I can look at your configuration in specific – it still seems to be working for me, but the more information I can collect the better.

    PHP 7.1 Woocommerce 3.0.9. WordPress 4.8. Strength Requirement is set to Anything. Need to have 9 characters to get Password ok message.

    Plugin Author Danny Santoro

    (@danielsantoro)

    Automattic Happiness Engineer

    Hey Thune! Could you email help@viai.co with details and a link to your site? I’m not able to replicate on a test install, but I would like to see your site in action to see if there’s a workaround or problem I might be able to find.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not working in latest version of Woo’ is closed to new replies.