WordPress.org

Forums

Wp-Pro-Quiz
[resolved] Not working in IE (12 posts)

  1. sijo55
    Member
    Posted 2 years ago #

    I got a strange problem here:
    First I made a test quiz and it works fine in all browsers.
    Then I made a quiz for my users and it is not working in IE (Internet Explorer). Works fine in FF, Chrome, Safari and Opera.
    The problem in IE is that nothing happens when clicking the 'Start quiz' button.

    Any idea what causes this?

    The quiz is here

    http://wordpress.org/extend/plugins/wp-pro-quiz/

  2. sijo55
    Member
    Posted 2 years ago #

    I have done some more testing:
    The problem with IE is when I activate 'Execute quiz only once'.
    But I need it activated. Do you have a solution for this?

  3. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    Hello sijo55,

    With me everything is ok. Which IE version you have tested?

    I tested with IE8 and IE9 on your side.

  4. sijo55
    Member
    Posted 2 years ago #

    You are right xeno010 ;)
    That's because I have turned off the activation for 'Execute quiz only once' where the problem is.

    I need to activate it, but cant do that before I have a solution or fix for it.

  5. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    As I said, everything works.

    I tested with IE8 and IE9 on my site and on my test environment. ('Execute quiz only once' activate) - everything works.

  6. sijo55
    Member
    Posted 2 years ago #

    Ok, then I have to live with that..

  7. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    I would really like to help you but I can not find the error.

    You can enable this option temporarily? So that I can see the error.

  8. sijo55
    Member
    Posted 2 years ago #

    I have activated it now ;)

  9. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you very much.

    I found the error. It is up to the special characters in the Domain Name. I will fix the bug in version 0.15.

  10. sijo55
    Member
    Posted 2 years ago #

    Happy days are back again ;)

  11. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    So version 0.15 is online.

    I've added a new option "jQuery support cors" to "In case of problems".
    enabled this - then everything should work. :)

  12. sijo55
    Member
    Posted 2 years ago #

    Now it's working. ;)
    Thanks a lot for your kindness and help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wp-Pro-Quiz
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.