Support » Plugin: Very Simple Contact Form » Not Working in Firefox Problem

  • Hi Guido,

    I know this was discussed in this closed post but never resolved:
    https://wordpress.org/support/topic/not-working-with-firefox-6/

    Was there a resolution? I’m having the same issue using FF 78.10 on a Mac. Safari works fine. I fill out the form, submit, and nothing. No message, no email. If I don’t use the right captcha number it fails and I get a notice. Same thing if I don’t use the minimum number of characters in the comment area. I’ve tried it logged in and not logged in. I’ve tried it with all FF plugins disabled one at a time until all were, no luck. The ONLY way it works in FF is when I restart in safe mode with all plugins disabled. Then it works. But not with all plugins disabled while not in safe mode.

    I was hoping I could isolate a particular FF plugin that was the cause but no luck so far. I can’t explain it. Perhaps something with the FF security features? I love this plugin but will have to switch if it won’t work. Especially if this is related to a popular plugin used in FF, but at this point I can’t determine that. I’m not quite sure I understand why a PHP form won’t submit properly in FF. Could it be the aria-required tag? Grasping at straws.

    creed3

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi,

    I don’t have a Mac myself, so not able to reproduce this.

    I fill out the form, submit, and nothing. No message, no email.

    After pressing submit, can you open the FF-inspector and click the console tab? Do you get an error notification there?

    And your FF-browser isn’t blocking Javascript?

    Guido

    Thread Starter creed3

    (@creed3)

    Ah, I had not thought of the console. Unfortunately nothing there pertaining to this. One warning about a CSS problem in another plugin, and one warning of a jquery problem for another plugin. And no, not blocking javascript. In fact console returns POST of apache code 200, no errors. I tried a different plugin with no other changes than the plugin itself and it does work. I really don’t get it. Thanks for your time!

    Plugin Author Guido

    (@guido07111975)

    This is very strange.

    The first thing it does after submission is “approved”, is saving the submission in the database. Does it save there? For this you need to activate this feature, via the VSCF settingspage.

    And do you have a (test)page online?

    Guido

    Thread Starter creed3

    (@creed3)

    So I activate the List form submissions in dashboard option. I get the Submissions page but no amount of submitting the form in FF shows up there. Are they stored in a separate table? My form is here: http://creed3.com/c3/contact-us/

    This must be a javascript thing with my browser setup or a browser plugin conflict that is not apparent since it does work in safe mode. I disabled every browser plugin one at a time and found nothing. Curious how if I submit the form incomplete or with an incorrect captcha number I get the appropriate error message. So the form is clearly communicating with the server.

    Plugin Author Guido

    (@guido07111975)

    First, thanks for helping me troubleshooting this..

    Cannot access that page: Forbidden.

    So the validation part does work, but the submission part doesn’t.
    If validation succeeds, this happens (in this order):

    1) Form is being stored in database (if feature is active)
    2) Submission is being send via email
    3) Success page is being generated (via Javascript)

    So you and I think it’s Javascript related, but in that case you expect that step 1 and 2 do work. But they don’t.. You do have latest version of my plugin?

    Guido

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not Working in Firefox Problem’ is closed to new replies.