Support » Plugin: Allow PHP in Posts and Pages » Not working in EXCERPT

  • I love the plugin as do many of the users. I am having a problem that I hope you could sort out.

    I have 2 WP sites that pretty much mirror each other. One is for development and and one the live site.

    On the DevSite, I have used your plugin in the EXCERPT without issue. But on the live site, your plugin works everywhere except the EXCERPT. All that shows is the text,
    [php] include_once ("includes/bucket-Solution-MobileApplicationRoll.php"); [/php]

    Have you every come across this? Is it the way wordpress is calling the EXCERPT?

    http://wordpress.org/extend/plugins/allow-php-in-posts-and-pages/

Viewing 4 replies - 1 through 4 (of 4 total)
  • P.S.
    The same code works perfectly if I put it in page content section.

    After not getting a reply from support, I installed another plugin (insert_PHP) to accomplish the same thing. It did not work either so I deactivated the new plugin. I then moved all the PHP code from my excerpt and into the content area in order to get the page to display correctly.

    This is still a great plugin despite this little issue. I still do not know why it behaves differently on two identical sites.

    Plugin Author Hit Reach

    (@hit-reach)

    Hi Ibeedug,

    We generally stick to support though our website http://www.hitreach.co.uk/wordpress-plugins/allow-php-in-posts-and-pages so we do not check this often

    It could be that your theme doesn’t execute shortcodes on the excerpt so it is not being parsed in the excerpt

    To get the advanced filter working try adding the following to your theme’s functions file:

    add_filter('the_excerpt', array( __CLASS__, "shortcode_advanced" ),0);

    Hope this helps,
    Hit Reach

    same problem here, the filter unfortunately makes no difference

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working in EXCERPT’ is closed to new replies.