Support » Plugin: Classic Editor » Not Working in 5.7

  • When I enable this plugin and try to edit a post, it goes to a 404 page, not found.

    When I disable the plugin I can update posts.

    However my theme requires this plugin, especially for blocks etc on home page editing…..you say in a post that it is compatiable with 5.7, but I am not finding this to be so, also in WordPress and here: https://wordpress.org/plugins/classic-editor/ it is showing as not tested to 5.7

    Please advise, if it won’t work with 5.7 I will have to ask for refund for theme I just purchased (The New Mag theme)
    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Kanger

    (@kanger)

    I also get this error message on the 404 page…

    Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /home/marblede/public_html/runbikehappy.com/wp-includes/functions.php on line 4759

    bstocker

    (@bstocker)

    Hello Kanger

    Maybe this Thread on Stackoverflow will help you:
    https://stackoverflow.com/questions/38693992/notice-ob-end-flush-failed-to-send-buffer-of-zlib-output-compression-1-in

    If you are using cPanel, disabling zlib.output_compression will help.

    Kind regards

    Thread Starter Kanger

    (@kanger)

    I have looked at that page, and implemented the second solution…below…

    I wouldn’t recommend disabling the wp_ob_end_flush_all() function entirely, and I definitely wouldn’t turn off zlib.output_compression in your php.ini file. Here’s a better approach that replaces the source code causing the issue, and preserves the underlying functionality:

    /**
    * Proper ob_end_flush() for all levels
    *
    * This replaces the WordPress wp_ob_end_flush_all() function
    * with a replacement that doesn’t cause PHP notices.
    */
    remove_action( ‘shutdown’, ‘wp_ob_end_flush_all’, 1 );
    add_action( ‘shutdown’, function() {
    while ( @ob_end_flush() );
    } );
    More details on the cause, and why this is probably the best approach can be found here: Quick Fix for WordPress ob_end_flush() Error`

    But maybe I should try the solution mentioned in first reply and just disable it…whereabouts in cpanel will I find zlip.output….?

    thanks

    Thread Starter Kanger

    (@kanger)

    actually no worries found it in cpanel, just testing wordpress site to see if that has fixed it, thanks

    Thread Starter Kanger

    (@kanger)

    yes not fixed the issue, I no longer get the ob_flush error message but it still goes to a 404 page when I update a post….when I disable classic edit, my posts update without any issue….

    • This reply was modified 6 months ago by Kanger.
    bstocker

    (@bstocker)

    Hi Kanger

    The Classic Editor is working fine here. Do you have a opportunity to check the Webserver logs? Maybe there are some more informations in apache/error.log. The access log will tell you what ressource cannot be found.

    Regards

    Thread Starter Kanger

    (@kanger)

    can’t see anything showing in web server error logs…

    when I click update it’s going to domain/wp-admin/post.php rather than domain/permalink

    Thread Starter Kanger

    (@kanger)

    Spent an hour with host this morning, there are no issues server side, no errors, mod rule etc it is all fine server side and is an issue with the plugin….

    when I click on update (on a post) I can a blank white screen (no 404 page or error message) with the link domain/wp-admin/post.php the edit actually saves but it’s annoying that it keeps going to a blank page and doesn’t revert to editing page…

    please can this plugin get fixed, really need to complete site asap

    bstocker

    (@bstocker)

    Hi Kanger

    Some more troubleshooting ideas:

    * Delete the Classic Editor Plugin and reinstall it. Make sure that there are no files remaining in the plugins/classic-editor/ Folder after uninstalling.

    * Disable other Plugins. Maybe another plugin is incompatible when installed together with the Classic Editor

    * Have a look at the .htaccess File. Maybe there are rules genararing this error!

    Hope this helps
    Regards

    Thread Starter Kanger

    (@kanger)

    Thank you for troube shooting ideas…I deactivated all plugins except for Classic Editor and it worked ok….so then reactivated one by one…found the plugin causing the issue…deleted that plugin and then reinstalled it….and now all working great….so does appear to work in 5.7

    Thank you so much for the ideas

    bstocker

    (@bstocker)

    Hi Kanger, thats’ great! Thanks for letting me know.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Not Working in 5.7’ is closed to new replies.