WordPress.org

Forums

WP Ajaxify Comments
Not working! Help please! (15 posts)

  1. samdg
    Member
    Posted 1 year ago #

    Ajaxifying doesn't seem to work on my site, pages refreshes after comment.
    http://goo.gl/rkqZ4f
    Could it be a js conflict? or selector issue maybe?
    Also, the notification text on the top goes behind the sticky menu.
    Please help.

    https://wordpress.org/plugins/wp-ajaxify-comments/

  2. kevinweber
    Member
    Posted 1 year ago #

    It's working when I visit your site: No page refresh …

    This custom CSS should fix your sticky-menu-issue:

    #sub-menu { z-index: 8; }
    #sticky-bar { z-index: 10; }
  3. samdg
    Member
    Posted 1 year ago #

    When you're posting via inline comment, it doesn't refresh while posting, but when you click the close button, the page refreshes.

    For regular comment section, it does refresh while posting comments.

    Also the sticky menu issue doesn't seem to have gone completely.

    Can you please take another look?

  4. kevinweber
    Member
    Posted 1 year ago #

    I don't see what's wrong with the sticky menu …
    Maybe the opacity of the notification bar confuses you. You can change opacity:

    1. Go to the options panel of WP-Ajaxify-Comments
    2. Insert into the "Opacity (%)" field 100

    Regarding the closing "x": I will have a look in two weeks or so. Is the "cancel" link working? (The link is not visible right now, so please test it for me.)

    Best,

    Kevin

  5. samdg
    Member
    Posted 1 year ago #

    Thanks for the opacity thing.

    I had the "cancel" link enabled and clicking it too refreshes the page.

    Also, when you comment via inline comments, the comment appear only in the inline comment section, but not in the regular comment section, if you don't refresh the page.

  6. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    do the problems still exist? Are they related to the "inline-comments" plugin? If so, Kevin are you working on a solution?

    Best regards,
    Jan

  7. samdg
    Member
    Posted 1 year ago #

    Hello,

    The problem persists even with inline-comments disabled. I think it's a javascript conflict with the theme, maybe?. Would you mind taking a look at it?

  8. kevinweber
    Member
    Posted 1 year ago #

    So as I understand it, the conflict is not caused by Inline Comments. Nice to hear. However, I wish you (@samdg) can solve the problem.

    Best regards,

    Kevin

  9. samdg
    Member
    Posted 1 year ago #

    Thanks, now let's see if jonas can help resolve the issue...

  10. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I need to take a look at your page but unfortunately the link http://goo.gl/rkqZ4f seems to be down (it just shows an empty page)...

  11. samdg
    Member
    Posted 1 year ago #

    Can you check once more? The link seems to be alright from my end.

  12. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Have you disabled the Inline Comments plugin? If yes, please reset all WP-Ajaxify-Comments options to the default settings.

    Hope this helps.

  13. one4thrd
    Member
    Posted 1 year ago #

    I am using the Optimizr theme and my web browser is Safari. This is a new blog with 2 entries. I cannot see any comment form after I activated this plug in. I am a newbie to all of this. Help! My site is Keithwallin.com/wp

  14. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    @one4thrd: Do you see a comment form when disabling the WP-Ajaxify-Comments plugin? The plugin just uses the existing comment forms and adds some AJAX-logic, rendering the comment form is not part of the plugin. And please open a new thread if you still have problems with the plugin.

    Hope this helps...

  15. kevinweber
    Member
    Posted 1 year ago #

    Hi @samdg,

    I found an issue that will be fixed with the next update (v1.7.1 or higher; not published yet) that might relate to your issue:
    When WP-Ajaxify-Comments is enabled and a comment was submitted, and when then the user wants to close the wrapper using the cancel link or "x", the page reloads.

    I'm going to implement the following ajaxStop function:

    $(document).ready(handleClickCancel()).ajaxStop(function() {
    handleClickCancel();
    });

    Regards,

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Ajaxify Comments
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.