WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Not working for me – maybe a conflict with my set up? Another plug-in?

[Resolved] Not working for me – maybe a conflict with my set up? Another plug-in?

  • Hi… I activated your plug in. The “Switch To” appeared for me on user list. I click it… and it puts me in the back end log in screen.

    I guess it must be another plug in I am using in my set up making it do that. Not sure which. This seems like a helpful plug-in. As I give permissions, capabilities… I want to see “what shows up” in their dashboard. I’ve been just using a second account of my own logging in and out of that to test.

    Does using social login create an issue with this? Or would it be a security plug in? I’ll try to figure it out… but if anyone knows.. would be helpful.

    Thanks!

    https://wordpress.org/plugins/user-switching/

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem, it just never worked for me and have it installed since 2 years ago ! Never gave up ! Still trying !

    Hi… Yes, it’s a great concept. Maybe it is a redirect plug-in. I never tried unplugging every other plug-in to see where the conflict might be. Kind of waited to hear back. Did you ever uninstall all your plugins to see if that was it? We shall overcome! 🙂

    Plugin Author John Blackbourn

    @johnbillion

    Just about the only thing that might stop User Switching from working is an over-zealous security plugin or a plugin which messes with the login screen in non-standard ways.

    Would you both let me know which plugins you have active please?

    Plugin Author John Blackbourn

    @johnbillion

    Also, it goes without saying, please make sure you’re running the latest version of User Switching (currently version 0.8.9).

    This time I actually spent some time and found the issue. I have a plugin that replaces /wp-admin with a custom name ( ie. /users ) to add a level of security and the *Switch To* link is pointed to that custom url :
    http://yoursite.com/users?action=switch_to_user&user_id=37&_wpnonce=f18149bd0a

    I replaced the custom url with the stock value and it worked :

    http://yoursite.com/wp-admin?action=switch_to_user&user_id=37&_wpnonce=f18149bd0a

    Just a note : I did not deactivate that other plugin or made any changes in the plugin’s settings. I simply copied the *Switch To* link for the user I wanted to switch to in a new browser tab and replaced that part of the URL manually.

    Hi John and alimoosavi15,

    You are my heroes. 🙂 Because I have a security plug in that replaces some things relative to a url for security reasons. I really appreciate these security plug-ins. But,that is what it is then.

    K, I am going to try to follow your “switch to” directions.

    Thanks for the great work on the plug-in, John. **I dunno if anything can be done on the plug-in side in “edit” of the plug-in to help us with this so we can just use the plug-in itself… since we are non-standard in log-in url???

    Thanks again!

    Plugin Author John Blackbourn

    @johnbillion

    Would you both let me know the name of the plugin(s) in question please?

    Hi John. I use WP Security. With that plug-in, I renamed my login page URL as Brute Force Prevention.

    Thanks!

    Hi John, I’m also using the WP Security plugin but the URL redirection for /wp-admin is from the *Lockdown WP Admin* plugin.

    Hi… with WP Security plug-in, I was able to “uncheck” the option to change the login page URL. I unchecked it, saved, and tried your plug-in again. Works perfectly. 🙂

    So, it is possible for me to uncheck that option, use this switch users plugin to do maintenance by just checking to see “what users see” in their dashboard, and then re-check that change login page URL with the security plug-in.

    I’m learning. 🙂 So, it is a “fix” to use both plug-ins for various functions… just cannot use them “both” at the same time.

    Thanks for the help in tracking down “what it was”… I am happy with the fix. If it can be further improved so I don’t have to “undo” the Brute Force Prevention while doing the “switch user” maintenance… that would be great. But, I’m happy just knowing what it is and how to work with both.

    Thanks!

    Plugin Author John Blackbourn

    @johnbillion

    Thanks for the testing Laura!

    You may want to report a bug with the WP Security plugin in that case. I’m sure they’ll be happy to look into fixing the issue.

    John

    Hi John… I didn’t check with the security plug-in author.

    Just passing along in case it is of interest to anyone. **I appreciate the security plugin authors. But, I am trying managed hosting. Security and caching is done for me. This plugin works with GoDaddy managed hosting.

    Thanks!

    Laura Lee

    I am using this plugin and I won’t mind using the work around, but when I try to enter the information, I get the question

    Are you sure you want to do this?
    with no other options
    no yes or no nothing else so I can’t proceed.
    I have memberships pro, affiliates pro, and a plugin to redirect users on my site so I’m not sure if these are causing redirect isuses.

    I’d love to know the fix for this because I’d like to manage my users custom profile fields that I can’t see from the front end. Right now I do not see the information.

    Plugin Author John Blackbourn

    @johnbillion

    delbra: Please try deactivating your other plugins one by one until you find the plugin which is causing the issue. Your best bet is then to contact the plugin author and ask them to look into it.

    If it turns out to be an issue with User Switching then feel free to open a new thread.

    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Not working for me – maybe a conflict with my set up? Another plug-in?’ is closed to new replies.