Support » Plugin: Voice Search » Not working for me either

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Hi Sheila

    Thanks for your report!

    Since the search form in the Divi theme is initially hidden, the plugin cannot calculate its dimensions, hence the button appears to be of size 0x0px (= invisible).

    I’ll try to create a fix over the weekend and will let you know when it’s ready.

    Cheers
    Pascal

    Cool…I figured it was something simple. I’ll watch for your update. THANKS!

    Plugin Author Pascal Birchler

    (@swissspidy)

    Good news! I spent ~1 hour optimizing the plugin so it works better in scenarios like this. The result is version 1.2.0, which is now available from WordPress.org. You should see an update notice in the admin area too.

    Afterwards the search form on your site will look like this in Chrome: https://cloudup.com/cQWLCGxurd8 (other browsers don’t support voice search at the moment)

    If you like the plugin, please consider submitting a review. Thank you 🙂

    AWESOME! Thanks for the fast service!

    I just updated it and indeed the microphone appears AND after telling Chrome it’s OK to allow the microphone access (PITA) it does enter what I say but it doesn’t seem to then search unless I manually click. In fact… I cannot do a typed search at all, it just keeps asking for mic access. And as far as I can tell NOTHING allows Chrome to complete the search either by typing or by voice. What am I missing here? Will need to remove this entirely sometime later today after you’ve seen what it’s doing….

    Plugin Author Pascal Birchler

    (@swissspidy)

    Yikes, that sounds like you found a pretty bad bug!

    Instead of submitting the search form when pressing enter, it would just trigger the microphone button again.

    The good news is: I have fixed this now in version 1.2.1!

    Another bonus is that I shortened the pause after the speech input a bit, so the text should appear faster.

    Can you confirm it’s working with the new version? Thank you very much for your help!

    WOW…you’re FAST! Yes, that works now. Thank you. It’s unfortunate that the way Chrome works it requires approving the microphone each time AND hitting return or something else. So it’s only slightly voice activated. But better than nothing and I imagine the browsers will catch up at some point. Thanks so much for all the help. Have a great weekend.

    Plugin Author Pascal Birchler

    (@swissspidy)

    Glad it’s working now!

    Unfortunately the implementation really isn’t that great yet. Approving the microphone each time can be avoided though if you use HTTPS on your website.

    Besides that, I can assure you that future changes will be reflected in this plugin where possible.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not working for me either’ is closed to new replies.