Support » Plugin: File Away » Not working for me at all

  • When I install it, I start getting this error in my page.

    Notice: Undefined index: is_safari in /home/nzin2020/dev.nzin2020.nz/wp-content/plugins/file-away/lib/cls/class.fileaway_definitions.php on line 27

    I do have debug turned on.

    Even then, when I put [fileaway] as a shortcode into a page, that doesn’t work. It just shows the page with a title.

    I guess all this is because the plugin is 3 years old?

    Is there any possibility of updating it?

    Cheers,
    Norm

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author thomstark

    (@thomstark)

    is_safari is a global defined by WordPress: https://codex.wordpress.org/Global_Variables

    If it isn’t defined for you, you have some other plugin undefining it somewhere.

    File Away actually is working. If there are no files in the folder you’re pointing to, it will output nothing, like it isn’t there. If there are only folders and no files, it will only output something if you have recursive=on or directories=on in your shortcode, as explained in the tutorials.

    • This reply was modified 7 months, 3 weeks ago by  thomstark.

    am using this plugin on wp 4.9.6 php 7 and is working fine. but am concerned that is no longer supported wonder if Mr. Stark or anyone else will ever consider taking over updates, as there appears to be no other plugin like this. Fileaway is perfect for what i am doing: uploading, viewing, sorting files from the front end.

    oh, and one other thing: is it possible to make the table responsive? have tried using % for width, but not working for me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not working for me at all’ is closed to new replies.