Support » Plugin: WP Proxy » Not working for me

  • Resolved RuGaRR

    (@rugarr)


    When I change the proxy settings and test it, my website still has the same IP address… what am I doing wrong?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author sleepm

    (@sdffamt)

    did you set domains?
    default is ‘*.wordpress.org’

    hi sleepm,

    i saw this support thread,
    so if i get it right, this plugin basically will monitor outgoing requests to a certain domain

    and if a certain domain meets the wp-proxy domain settings, then this domain will be channeled through the predefined proxy server, and all other requests from the wordpress will go through the server ip without interference ?

    Plugin Author sleepm

    (@sdffamt)

    yes
    use ‘pre_http_send_through_proxy’ filter to check domains

    MAY i ask where do i use the pre-http-send-through_proxy

    because in my understanding, i define the domains and then the wordpress knows to access these domains from wordpress automatically.

    the use case for me is this
    https://www.webtoffee.com/woocommerce-import-products-with-images/

    i use this plugin to import images, but if i import images from 1 ip of the server, the ip is blocked, this is why i want to use stormproxies in order to randomize the ips that download the images

    Plugin Author sleepm

    (@sdffamt)

    sorry, i mean ‘wp-proxy’ use ‘pre_http_send_through_proxy’,
    ‘wp-proxy’ can’t dynamic change proxy server setting

    this is not the issue, since i get 1 proxy from luminati.io and in the proxy it self on luminati backend, i set several countries, so every query to the proxy changes the ip.

    the issue is, how do i make the wp-proxy download images from cnn.com through the proxy,
    do i write *.cnn.com or i need to write cnn.com and money.cnn.com and every other subdomain?

    Plugin Author sleepm

    (@sdffamt)

    i see ‘product-import-export-for-woo’ file /includes/importer/class-wf-prodimpexpcsv-product-import.php line 4139 function fetch_remote_file use ‘wp_remote_get()’ to fetch image, it should work.
    could you please provide some images url, or you can self check that url include 301 redirect or some thing

    the issue was solved, instead of keying *.domain.com i entered domain.com and it did the magic !!!

    THANK YOU !!!

    Plugin Author sleepm

    (@sdffamt)

    you are welcome
    and 1.3.9 is release, it add global mode.

    what do you mean global mode

    aka

    *.domain ?

    Plugin Author sleepm

    (@sdffamt)

    all the traffic will through the proxy

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Not working for me’ is closed to new replies.