WordPress.org

Forums

MailChimp for WordPress
[resolved] Not working for me (3 posts)

  1. Herbalsauce
    Member
    Posted 2 years ago #

    I followed the install directions, placed in my mailchimp API key and selected the list that I wanted to export the email addresses to. However, when I fill out the form: name, email, and click the subscribe button, comment posts fine but the email address was not added to my list on mailchimp. Any ideas?

    http://wordpress.org/extend/plugins/mailchimp-for-wp/

  2. Herbalsauce
    Member
    Posted 2 years ago #

    When I post a comment, I get redirected to another page with this error message:

    Warning: Missing argument 2 for MC4WP_CommentSubscriber::subscribe() in /home1/herbal/public_html/wp-content/plugins/mailchimp-for-wp/includes/class-mc4wp-commentsubscriber.php on line 42

    Warning: Cannot modify header information - headers already sent by (output started at /home1/herbal/public_html/wp-content/plugins/mailchimp-for-wp/includes/class-mc4wp-commentsubscriber.php:42) in /home1/herbal/public_html/wp-includes/comment.php on line 619

    Warning: Cannot modify header information - headers already sent by (output started at /home1/herbal/public_html/wp-content/plugins/mailchimp-for-wp/includes/class-mc4wp-commentsubscriber.php:42) in /home1/herbal/public_html/wp-includes/comment.php on line 620

    Warning: Cannot modify header information - headers already sent by (output started at /home1/herbal/public_html/wp-content/plugins/mailchimp-for-wp/includes/class-mc4wp-commentsubscriber.php:42) in /home1/herbal/public_html/wp-includes/comment.php on line 621

    Warning: Cannot modify header information - headers already sent by (output started at /home1/herbal/public_html/wp-content/plugins/mailchimp-for-wp/includes/class-mc4wp-commentsubscriber.php:42) in /home1/herbal/public_html/wp-includes/pluggable.php on line 876

  3. Danny van Kooten
    Member
    Plugin Author

    Posted 2 years ago #

    Hey herbalsauce,

    Thank you for opening a support question and for providing me with the error notices that popped up.

    A few questions, which WordPress version are you running and are you running Akismet or a similar anti-spam plugin?

    I made a small change in the plugin which should fix your issue but I'm still curious what is causing it. I didn't release the change as a new version so could you try re-downloading the current version of MailChimp for WordPress to see if it fixes your problem?

    Thanks.

    Danny

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MailChimp for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.