Support » Plugin: WP Resized Image Quality » Not working for me

  • Tested same file with different names for upload and turned compression to 0 none. Not different in size and the 3 smaller sizes were not generated.

    Anyone know how to currently turn off WP compression. I take care of file size in PSP thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mike Bijon

    (@mbijon)

    Hi @dano55,
    If your site isn’t changing the filesize, then it’s possible that your server host hasn’t installed or turned on a compression library. Here’s a PHP script for seeing if ‘ImageMagick’ is installed, you can probably search for one that will check on ‘gd’ too:
    * http://stackoverflow.com/questions/4208253/verify-imagemagick-installation

    As for turning off compression entirely:
    WordPress’ image compression settings work in reverse. So setting compression to 0 means the MOST compression, but setting it to 100 means NO compression. So add this line of code to your functions.php file (or just set this plugin to compression level 100:

    add_filter( 'jpeg_quality', 100 );

    Thank you for the advice Mike. Being a pro photographer for many years it’s driving nuts how compressed my images end up.

    Will try you suggestion later as I have bigger fish to fry.
    will try you plugin again….

    Dan

    Plugin Author Mike Bijon

    (@mbijon)

    Hi all. The support thread @zehawk linked to above is resolved. There was a misunderstanding about what 0% & 100% meant, and the plugin worked fine.

    I’ll update help text in WP-RIQ, but for wrap-up here:
    * 100% setting (aka, 100% quality) ==> Least compression & biggest filesizes
    * 0% setting (0% quality) ==> Most compression & smallest filesizes

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working for me’ is closed to new replies.