Support » Plugin: Optimize Images Resizing » Not working because of image_get_intermediate_size

  • Hey,

    This plugin advertises to do exactly what I’d like, however I’ve not found it functioning. I’ve done some debugging and in file class-resize-image.php

    if ( $intermediate = image_get_intermediate_size( $id, $size ) ) {

    if I remove that block, so it always processes the ‘else’ then it works as I wish.

    I’ve not really read the code to understand how it works – but this doesn’t seem right to me. Is it possible another plugin I have is conflicting – if so any idea what to look for?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author OriginalEXE

    (@originalexe)

    Hello,

    apologies for the late reply.

    That line checks whether the size already exists for the current image, looks like it for some reason reports that it does even though it’s not? What is the result, you get broken images on the frontend?

    I can’t recall exactly and have removed the plugin now, I think it was just not generating the thumbnail and serving up an alternative size instead. If I try it again and have the same problem I’ll let you know.

    The result is simple that the thumbnail does not get created – so WordPress behaves as it would usually (i.e. your plugin doesn’t generate it, so WP uses the next bigger image).

    ah actually, WooCommerce is getting in the way with it’s placeholder. I’m trying to have a dig to see if I can see where.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not working because of image_get_intermediate_size’ is closed to new replies.