Support » Plugin: Post Duplicator » Not working as a MU plugin – please enable it?

  • 1. Clean Roots Bedrock/Sage WP install
    2. Add plugin as a Must Use plugin via Composer (WPackagist): "wpackagist-plugin/post-duplicator":"2.22"
    3. try do duplicate any post in admin
    4. Nothing happens + there is an error visible in dev tools console:
    "Uncaught SyntaxError: expected expression, got '<'"

    If installed as a normal plugin and manually activated, it works normally.

    The problem seems to be in the hardcoded path to JS files, namely this GET request happens: Yourpage.local/app/plugins/post-duplicator/assets/js/pd-admin.js?ver=2.22. This should be mu-plugins when activated automatically I reckon.

    How can I have the plugin installed as a MU plugin without errors?
    Don’t mind adjusting it myself if you provide access to the repo.

    • This topic was modified 6 months, 2 weeks ago by trainoasis.

    The page I need help with: [log in to see the link]

  • The topic ‘Not working as a MU plugin – please enable it?’ is closed to new replies.