WordPress.org

Support

Support » Plugins and Hacks » Easy FancyBox » [Resolved] Not working after 1.5.0 update – css related

[Resolved] Not working after 1.5.0 update – css related

  • Like many others here, I was having problems with Easy Fancybox after doing the 1.5.0 update. My problem was that clicking on images did not bring them up in the lightbox, but did load them at the bottom left of the page.

    I’ve spent 2 days researching the problem, and have done everything suggested including shutting off all of my plugins except Easy Fancybox and I changed themes over and over again.

    I have a theory that the problem might relate to the “deflation” of the css file done at the beginning of the easy-fancybox.css.php file and how that is handled on certain servers – especially shared hosting platforms where there isn’t much enduser control.

    The only working solution I have found is to make a change to the easy-fancybox-class.php file, line 469 (at or about).

    Change this:
    wp_enqueue_style('easy-fancybox-css', EASY_FANCYBOX_PLUGINURL.'easy-fancybox.css.php', false, FANCYBOX_VERSION, 'screen');

    To this:
    wp_enqueue_style('easy-fancybox-css', EASY_FANCYBOX_PLUGINURL.'fancybox/jquery.fancybox-1.3.5.css', false, FANCYBOX_VERSION, 'screen');

    Doing that brings the jquery.fancybox css file into the header, without any deflation.

    The only problem with doing that is subsequent updates will destroy the modification. It also doesn’t solve the problem, it just puts a bandaid on it.

    I would be curious to know what the php requirements would be for this plugin? I can’t seem to locate any information regarding that and it might help me fix the problem for all sites I need to update.

    http://wordpress.org/extend/plugins/easy-fancybox/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author RavanH

    @ravanh

    Hi MacDoodle, there should be no special PHP requirements for the easy-fancybox.css.php but the problem you describe is indeed an indication of the stylesheet failing.

    Can you share a URL to your site where you have done this workaround?

    It’s on a development server, I’d rather not post a public link – any other option?

    Plugin Author RavanH

    @ravanh

    Can you post a URL via http://status301.net/contact-en/ or is it not publicly accessible at all?

    sent via your contact form. 😉

    Plugin Author RavanH

    @ravanh

    Wow, that’s fast… Will have a look. Thanks 🙂

    Plugin Author RavanH

    @ravanh

    Ok, the dynamic (php) stylesheet request is returning a 403 Forbidden response. Could you check the easy-fancybox.css.php file permissions on your server?

    I was just talking to an associate – wondering if maybe the issue might be the server won’t let the php file run as a css file even though the header is sent correctly in the easy-fancybox.css.php file. Something to do with a mime type or mod? That would explain why it’s working for some and not all.

    permissions are 644 (rw-r–r–)

    BTW – there is nothing special in the root or subfolder htaccess file. Permalink structure is the only thing in the wp htaccess. And this is not the only site I’m having trouble with this, on this host.

    Plugin Author RavanH

    @ravanh

    I have no idea why the server would throw a 403 Forbidden response otherwise. Could you test with setting permissions to 755 ?

    Plugin Author RavanH

    @ravanh

    I cannot even access the readme.txt file in the easy-fancybox folder directly. But css, js and image files are accessible. There is definitely something allowing only some file types to be accessed directly on the whole server… Like not even the usual /license.txt in your site root.

    755 is done.

    Let me go see what I can break in the cpanel.

    Plugin Author RavanH

    @ravanh

    Are there any other .htaccess files beside the one in the root of the site? Either further down or up the dir chain… Or maybe in the Apache config file, there is something like discussed on http://stackoverflow.com/questions/4982441/restrict-access-to-a-directory-by-file-type which could explain these 403s.

    In any case, I have been thinking about an option to use the static stylesheet before since less and less people are using IE6/7 any more… I’ll consider moving that into the next release.

    I think I have an answer – on the phone with the hosting company, and the person I’m speaking to seems to think the restriction may have something to do with restrictions that were put in place back in April when there was issues with WP hacks happening. I’ve been on and off hold for quite a while now… They don’t want to do any support because technically 3rd party, but he’s trying to be helpful.

    Plugin Author RavanH

    @ravanh

    Ok, that could indeed explain it. A very effective way of locking things down… Using the static CSS file is the only solution then. 🙂

    I have an answer – bear with me because I only know enough to be dangerous at the server config stuff.

    Across the shared server, certain wp folders were locked from browsing because of all the hacking attempts. Files that were allowed to be accessed thru the lockdown included images, js & css files. PHP files were not allowed (for browsing) because they are not intended to be browsed/direct accessed at that level.

    I can override it with an htaccess file, but his opinion is that if I do that, then it opens up what was closed for security.

    Soooooooo. Yeah, static css file it is. At least the next time something won’t work for no apparent reason, I’ll know where to look.

    This is JustHost / BlueHost hosting, btw. (I know. I know. Ugh.) So if it comes up again, you’ll know what to ask.

    RavanH, you have been stellar in your assistance! Thank you so much! I hope I didn’t eat up too much of your time!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Not working after 1.5.0 update – css related’ is closed to new replies.
Skip to toolbar