Support » Plugin: WP Edit » NOT WORKING: Abreviation & Insert/Edit Advanced Link

  • This hasn’t worked for as long as I can remember, but I’m finally calling it out.

    The ABBR dialog has the ABBREVIATION and the TEXT selections turned around. So it you want to try to employ best practices and have tip text for your abbreviations, you’ll have to remember they’re screwed up and opposite.

    Same thing, for tool tips or meta descriptions on links, for some reason WordPress doesn’t offer this natively, which seems like a strange oversight. Your “Advanced” link doesn’t work at all anymore, it used to at least work sometimes, but that’s all done now.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Josh

    (@josh401)

    Hello, and thank you for the information.

    1) I’m not sure I follow exactly what you are describing here. What do you mean they are “turned around”? Would renaming them make it easier to implement?

    2) I just tested the advanced link button, and it’s working properly. Are you referring to the “Insert/Edit Advanced Link” button?

    If you highlight an acronym and want a tooltip to pop up explaining what the acronym stands for, the Text field will actually be the acronym and the acronym field will actually be the text. They’re turned around, trust me. give it a try.

    The advanced link button will not work at all for me–if I want a tool tip or alt text on my link, I cannot do with your advanced link feature. It is broken.

    Plugin Author Josh

    (@josh401)

    Okay, I will adjust those words.

    Regarding the advanced link; can you please give me the steps to replicate the issue? Does the advanced link window open? Does it allow you to type your fields? Does it close when you click save? Exactly at what point does it break for you?

    Many thanks!

    Josh,
    the “Insert/Edit Advanced Link” button doesn’t work for me. If you do not experience what I detail below, perhaps it’s just my install.

    What should happen is when I’ve highlighted linked text (or set my cursor somewhere in linked text), and then click that button:

    • the dialog should prefill with the URL of the hyperlink. Currently it just shows the example text.
    • and it would be nice to see a “Target” default (I want all links to open in a new tab, so if the advanced link remembered the last choice, great)
    • To top it off, when I fill all that info in, and then click the “Insert & Close” button, nothing happens. The dialog stays open, nothing changes.

    The only reason I really want the advanced link to work is that it seems WP’s default link dialog doesn’t allow for “Title” text of hyperlinks.

    Thanks for looking into this.

    • This reply was modified 3 years, 1 month ago by KrisBunda3D.
    Plugin Author Josh

    (@josh401)

    I’ve just tested extensively. It is all working properly for me. I can use the “Insert/Edit Advanced Link” button to insert a link, define a target window, add class, id and title… and it inserts just fine.

    Additionally, when I edit a link I’ve created… all fields are auto-populated back into the “Insert/Edit Advanced Link” window.

    It sounds like you might have a js conflict with another plugin. Is it possible for you to deactivate all plugins except WP Edit and test again?

    Hey,

    I’m having some kind of the same issues with the Plugin. The Advancde Link was working properly for the past days but since today i get Errors. Chrome Console tells following issue: Uncaught ReferenceError: jQuery is not defined for /wp-content/plugins/wp-edit/plugins/advlink/includes/advlink.js.

    is this a well known issue? How to fix this?

    Thanks in advance for ur help.
    Sebastian

    Plugin Author Josh

    (@josh401)

    Hi Sebastian,

    Are you seeing this error when creating a post, or a page, or both? Or a custom post type?

    Hi Josh,

    thanks for ur quick reply.

    The issue appears on pages, posts and custom post types. I also deactivated other Plugins which I installed later but the issue was still there. There was no Update of the plugin itself so I’m realy clueless right now.

    I hope u can help me out ver soon.

    Thank u so far.

    Kind Regards
    Sebastian

    Hi Josh,

    I fixed it by my selfe. The jQuery library was not federated via https. So if u run SSL on ur website it wont load the resources. Maybe u can fix this within the next Update.

    Thanks and have a nice day
    Sebastian

    Plugin Author Josh

    (@josh401)

    Hi Sebastian, glad you got it working properly.

    I’ll definitely take a look at this before the next release. Thanks for the information. Please have a wonderful week.

    I have the same issue with the Insert/Edit Advanced Link button and have for a while now. You click the button and the form pops up, but it won’t do anything when you click Insert & Close button, it doesn’t do anything. Is there an ETA when it will be fixed?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘NOT WORKING: Abreviation & Insert/Edit Advanced Link’ is closed to new replies.