• I just installed this today and every attempt to use it, comes back with a message saying “reduced by 0(0 saved)” Am I doing something wrong? I tried bulk and individual. I tried uploading new images to see if it would work on them. I’ve gone into the settings – very few options available. Nothing is working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author reSmush.it

    (@resmushit)

    Hello Samantha3,

    You should enable logs in the plugin, and copy/paste here the content of your resmushit.log file located at the root of your WP installation.

    Best regards,
    Charles

    Here’s a chunk of it. It all looks the same:

    [05-04-2018 15:29:58] Revert original image for : /hermes/walnaweb09a/b1605/moo.thetalentedcrazycom/techcrazyva/wp-content/uploads/2018/02/Logo-fav.jpg
    [05-04-2018 15:30:05] Bulk optimization launched for file : /hermes/walnaweb09a/b1605/moo.thetalentedcrazycom/techcrazyva/wp-content/uploads/2018/02/cropped-Logo-fav.jpg
    [05-04-2018 15:30:05] Revert original image for : /hermes/walnaweb09a/b1605/moo.thetalentedcrazycom/techcrazyva/wp-content/uploads/2018/02/cropped-Logo-fav.jpg
    [05-04-2018 15:30:17] Bulk optimization launched for file : /hermes/walnaweb09a/b1605/moo.thetalentedcrazycom/techcrazyva/wp-content/uploads/2018/02/Signature.png
    [05-04-2018 15:30:17] Revert original image for : /hermes/walnaweb09a/b1605/moo.thetalentedcrazycom

    • This reply was modified 2 years, 1 month ago by samantha3.

    Hi, I had same problem. My log file looked like yours. I fixed it by enabling fopen wrapper.

    resmush log:
    [09-04-2018 13:40:26] Bulk optimization launched for file : /www/server.com/wp-content/uploads/2018/04/bh4.jpg
    [09-04-2018 13:40:26] Revert original image for : /www/server.com/wp-content/uploads/2018/04/bh4.jpg

    wp log:
    [09-Apr-2018 13:40:28 UTC] PHP Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /www/server.com/wp-content/plugins/resmushit-image-optimizer/classes/resmushit.class.php on line 69
    [09-Apr-2018 13:40:28 UTC] PHP Warning: file_get_contents(http://static1.resmush.it/output/59d6a3109563121bb01967270095a933/bh4-150×150.jpg): failed to open stream: no suitable wrapper could be found in /www/server.com/wp-content/plugins/resmushit-image-optimizer/classes/resmushit.class.php on line 69

    I hope I helped.

    • This reply was modified 2 years, 1 month ago by davidstrunc.
    Plugin Author reSmush.it

    (@resmushit)

    Hi David,

    Thanks for this reply, we’ll add this configuration as a prerequisite 🙂
    @samantha, does it help ?

    Cheers,
    Charles

    I have maybe a similar problem. Im using the newest Version of WordPress and your plugin. On click in the image library the smush button of a specific image nothing happend. No loading indicator and also after some minutes no response. The optimization of all images via settings page and the while uploading images works fine but needs a lot of time (7 to 15 seconds per image). In the developer log of the plugin is no error and also my server log doesnt give me any error.

    What could I do now?
    Best Lukas

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not working’ is closed to new replies.