• Resolved matiou

    (@matiou)


    Hello, first of all thank you for this plugin, it seems to work for some people but not me
    I would really appreciate if you could help me, looking at the website and telling me what i’m doing wrong because i really need to have an infinite scroll option working with google analytics and single pages..and your plugin is the only one!!!
    i’m in a child theme
    i declare in functions.php add_theme_support(‘auto-load-next-post’); should i wrap it in a function??
    i have a folder auto-load-next-post and inside of it a file content-partial.php
    it’s a custom theme so there are content-…php files but they point to a folder with blog layout
    blog-style 1 blog style 2 etc which are for the blog and categories layout
    i also have a single.php file which point to a folder with single-style-1 single-style 2 etc..
    inside these last file i have the code <article></aticle>
    what i did is putting all the code in <article></aticle> and put it in place of all the code with the condition on get_template_part…nothing’s happening..

    my pagination are custom and working with get_next_post and get_previous_post, is it ok???
    i reaaly don’t understand why it doesn’t work

    thank in advance if you have time for it
    http://virtualpics.fr/leshommesmodernes

Viewing 3 replies - 1 through 3 (of 3 total)
  • ok sorry sebastien, finally it works
    so for those who are in trouble with the plugin

    i simply create the folder auto-load-post and inside of it the file content-patial
    i erase everything in the file and put a loop with all my <article></article> code
    i took the pagination from your file in example

    <nav class="navigation post-navigation" role="navigation">
    		<h1 class="screen-reader-text"><?php _e( 'Post navigation', 'broden' ); ?></h1>
    
    		<span class="nav-previous"><?php previous_post_link( '%link', '<span class="meta-nav">' . _x( '&larr;', 'Previous post link', 'broden' ) . '</span> %title' ); ?></span>
    		<span class="nav-next"><?php next_post_link( '%link', '%title <span class="meta-nav">' . _x( '&rarr;', 'Next post link', 'broden' ) . '</span>' ); ?></span>
    	</nav><!-- .post-navigation -->

    wich is in the single.php file and in the content-partial theme
    i gave the selectors in admin, i tryed all the selectors and finally it works..
    at the begining it was very slow, but finally it is working normally now and analytics tracking is ok also..

    thank you again for this plugin sebastien!!

    finally i have still a problem, in google analytics the title is “not set”…
    do you know what is this??,
    the site is using seo by yoast..

    matiou

    (@matiou)


    sorry again, it was my selectors..i put .post-title in place of h1.post-title and it works..
    sorry for all these messages!!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.