Support » Plugin: NS Google Sheets Connector » Not working

  • Resolved Mr Wood

    (@mr-wood)


    This plugin is potentially exactly what I need, but I can’t get the free version working.
    I have followed the installation instructions and created a Google sheet and contact form 7 exactly as per the screenshot and instructions. The Google access code field on the settings page states that it is currently activated. My Google account has two factor authentication set up, will this make a difference?

    On submission the form gives the error message shown below and the debug log text file is completely blank.

    There was an error trying to send your message. Please try again later.

    Please help..

    https://wordpress.org/plugins/ns-google-sheets-connector/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Never Settle

    (@neversettle)

    I would first try re-authenticating the site with Google (and allowing for less secure apps, to see if that was affecting the connection).

    Then, if that doesn’t work – post a screenshot of your configuration and screenshot and we’ll take a look at it.

    ronyronaldo

    (@ronyronaldo)

    Hi,
    It’s also not working for me and I have recheked all the settings which seems to be fine.
    Below my setting:

    NS Google Sheets Connector

    Google Access Code
    “Currently Activated”
    Click here to retrieve your code from Google Drive to allow us to access your spreadsheets.

    Google Sheet Name: teste
    Google Sheet Tab Name: test
    Contact Form 7 ID to use: 48

    Corresponding page:
    [contact-form-7 id=”48″ title=”test”]

    Form:
    <label> Votre nom (obligatoire)
    [text* name] </label>
    [submit “Envoyer”]

    Google Sheet:
    2 columns : date & name

    Can you give me a help please?
    Regards,
    -R.

    ronyronaldo

    (@ronyronaldo)

    Link to the print screens:
    https://drive.google.com/open?id=0B7x3tczHabHPUWttUVRrcjBIZDQ

    Many thanks!

    Plugin Author Never Settle

    (@neversettle)

    Thanks for reporting this @ronyronaldo and providing those screenshots. On the surface it looks like you have it set up correctly. We just uploaded an update. Please try the following things:
    1) run the update to get the latest version (should be 1.2.2)
    2) reconnect the plugin to Google (repeat all the authentication steps)
    3) try a test submission

    If it still doesn’t work, please also:
    – provide the Debug Logs from the download link
    – let us know: are you also getting the email from the form submission?
    – do you see any errors in your php error log?
    – are there any errors in your browser inspector?
    – when you get submit the form do you get the ajax success notice?

    Also, I see that you are testing on a local machine. Can you test on a live or at least hosted site as well to see if that makes a difference?

    Cheers,
    NS

    Many thanks @neversettle!
    I’ll try and let you know.
    Cheers,
    R.

    @neversettle,
    I did what you’ve advised and I still get the same error…
    “Error when sending the message. Try agin later”.
    And I’m not getting any email from the form submission.

    Is this error meaning that the problem is when trying to send the email, and not when sending data to the form ?

    The NS Google Sheet Connector log file via the link is blank.
    I found in the file wp-content/debug.log this error:
    [18-Feb-2017 20:05:09 UTC] SSL certificate problem, verify that the CA cert is OK. Retrying with the CA cert bundle from google-api-php-client.
    Seems to be a certificate issur, wright ?
    How can I fix it please ?

    I don’t know if that can help but the authorization (from NS connector to my Google account) is not exactly the same as it is showing in the documentation.
    Instead of the authentification by user/password, the extension uses the Google Access Code. Can it be the reason ?

    It’s, as you said, on a local machine.
    Installing and running on a hosted site can fix this ?

    Thank you very much for your help on that !
    Cheers,
    R.

    Plugin Author Never Settle

    (@neversettle)

    SSL certificate problem, verify that the CA cert is OK.

    Yes – usually this means that there is a certificate problem on your machine which is most likely not configured with the proper Root CA cert needed by Google for the communication with it’s API. The plugin needs to make secure requests to HTTPS “endpoints” and those endpoints at Google have certificates that need to be trusted by your machine.

    Installing and running on a hosted site can fix this ?

    Yes – either you’ll have to install / update the root certs on your machine so that it can use the requests needed to Google. Or, running this from a normal hosted site – those servers almost always have the proper certs and configuration.

    Best,
    NS

    Plugin Author Never Settle

    (@neversettle)

    Closing this as we never heard back from you and considering this issue resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.