Support » Plugin: Proxy & VPN Blocker » Not Work Correct

  • Resolved Anonymous User 17894003

    (@anonymized-17894003)


    The backend menu no longer works properly.

    If we select a post that is blocked, it does so, but it also blocks the wp-login area which should not

    Since I use a VPN myself, I have to switch off the plugin every time to get into the admin area. Once we are logged in you can activate the plugin again.

    109/5000
    The admin area also looks different from the pictures. Searching is not possible, there is only one list

    Screenshot
    https://ibb.co/Pgw99fH

    • This topic was modified 1 year, 5 months ago by Anonymous User 17894003.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Anonymous User 17894003

    (@anonymized-17894003)

    Reinstall WordPress has corrected the view again.

    How to prevent blocking on wp-login.php? The Plugin Block the WordPress Admin

    Plugin Author rickstermuk

    (@rickstermuk)

    Hi @aybee2k2,

    If we select a post that is blocked, it does so, but it also blocks the wp-login area which should not. Since I use a VPN myself, I have to switch off the plugin every time to get into the admin area. Once we are logged in you can activate the plugin again.

    If working correctly, the plugin will always block wp-login.php for detected IP’s, this is not optional. You should be able to whitelist the IP’s of your own VPN with your proxycheck.io account but if this is a public VPN service this will also allow others through if connecting through the same IP/VPN Provider.

    The admin area also looks different from the pictures. Searching is not possible, there is only one list

    It does appear that the CSS/javascript for the plugin admin UI wasn’t loading and I’m not sure why that would happen, if it was Proxy & VPN Blocker causing this then reinstalling WordPress would not have fixed this but please let me know if it happens again!

    Thread Starter Anonymous User 17894003

    (@anonymized-17894003)

    I removed the code from the plugin that ensures that the wp-login.php is blocked by your plugin.

    It would be nice if you could choose that yourself in the future.

    I got the incorrect display fixed by reinstalling WordPress.

    Thread Starter Anonymous User 17894003

    (@anonymized-17894003)

    The time and date in the statistics is not correct.

    It would be nicer if the plugin got the date and time from the WordPress settings.

    So everyone can see the time in the country where he lives.

    Plugin Author rickstermuk

    (@rickstermuk)

    Hi, I agree that this would be nice to have, though this information is pulled directly from proxycheck.io Dashboard API, I have been in contact with them and they have changed it to display in the same way it does on the proxycheck.io dashboard (ie “30 minutes ago” or “2 days ago”), this change should be reflected within your Proxy & VPN blocker statistics page right now. Unfortunately we found it wouldn’t be possible to display based on WordPress time with a timestamp because of the way this information if formulated.

    There is however a patch for the pagination of this log in Proxy & VPN Blocker 1.6.0 (coming soon-ish!), it currently has an issue with skipping too many pages when scrolling back to older entries in Proxy & VPN Blocker, you may not have noticed this if you have a lot of entries and don’t scroll back far.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not Work Correct’ is closed to new replies.