Support » Plugin: Easy Testimonials » Not Very Happy: Contacting API Is Making Site Crawl

  • Resolved Brandon Olivares

    (@cocreation)


    Hello,

    Apparently your plugin is contacting http://future.theslatch.com/. But right now that site is erroring out. And since the timeout is 20 seconds, that means my site is loading in 20+ seconds, with every. single. load.

    I had to deactivate the plugin and will reactivate once this url is operational again.

    I’m not sure why it attempts to contact this API on every page load, but that seems rather inefficient.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author richardgabriel

    (@richardgabriel)

    Hey @cocreation!

    Thanks for the report!

    That response is supposed to be cached, and it should only be hit the first time the upgrade routine runs after you’ve been presented with a consent message.

    I believe you were seeing it hit repeatedly because the response was timing out and therefore not being cached. We’ve put out a quick patch that updates the API URL which should avoid the timeout and allow the response to be properly cached.

    If the issue persists for you in the most recent update please let me know and we’ll be sure to circle back!

    All the best,
    Richard

    Hi Richard,
    I am also experiencing this issue. The upgrade to 3.0.1 did not help. Its still causing major slowdowns on sites.

    Also having the same issue here, affecting several production sites… the update failed on one box and has no affect on others.

    EDIT: What consent message?

    • This reply was modified 3 years, 9 months ago by jimmyeao.
    Plugin Author richardgabriel

    (@richardgabriel)

    Hey @briantoy84 and @jimmyeao!

    Thanks for your reports, as well.

    We are aware of the issue causing slowdowns for users and are working on an update today to resolve this. In the meantime, if this is a current problem for you, I would roll back to version 2.3.1 of Easy Testimonials (the version you were on before performing the update) and stay tuned for an update from us.

    @jimmyeao — the Consent Message I referred to is for Pro users who updated to version 3. This message would show up giving our plugin permission to contact our server and download the new Pro add-on for those users.

    For anyone reading this, please know that we are aware of the slowdowns and are actively working on resolving the issue. If you are experiencing problems you can stay on version 2.3.1 for now as this thread will be updated as the issue is fixed.

    All the best,
    Richard

    Richard, many thanks for the update, hopefully, you can resolve shortly 🙂

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey @jimmyeao, @briantoy84, and @cocreation

    Version 3.0.2 should address the issue related to hitting the API on the front end of the website (this wasn’t supposed to be happening.) This patch should cease that behavior and therefor address any slowdowns that were related to it.

    When y’all have a chance will you follow up after upgrading and see if that helps out?

    I appreciate your patience as we work through this!

    All the best,
    Richard

    OK, so this has made a drastic improvement, although the admin site is still slow with this enabled, but I can live with that 🙂
    Thank you for the quick turn around on this, it is really appreciated.

    Thread Starter Brandon Olivares

    (@cocreation)

    Thanks @richardgabriel. Can confirm it works for me as well.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not Very Happy: Contacting API Is Making Site Crawl’ is closed to new replies.