Support » Plugin: WP Original Media Path » Not uploading to Subdomain

  • Resolved benjammin

    (@benjino)


    I migrated a WordPress site to a new domain > mynewdomain.com
    Then I created a subdomain and added directories > media.mynewdomain.com/wp-content/uploads
    Then I uploaded the year/mo. directories to uploads on the subdomain.
    Then I added http://media.mynewdomain.com/wp-content/uploads to > “Full URL path to files” field for the plugin, and saved. All of the images show up.

    But when I add http://media.mynewdomain.com/wp-content/uploads to > “Store uploads in this folder” field for the plugin it creates a subdomain named directory inside the main domain’s root, when the real subdomain director is outside of the main domain root. When I leave “Store uploads in this folder” empty the uploads go to wp-content/uploads of the main domain, but don’t show in the library.

    How do I get the images to upload to http://media.mynewdomain.com/wp-content/uploads when using the Media Library uploader?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author RVOLA

    (@rvola)

    Hello !
    It’s simple.

    If you leave the original folder location of the upload. Here’s what you need to do.

    Create the subdomain: media.domain.com and made the point in the wp-content / uploads folder

    Activate the plugin and fill like this:
    1 field: wp-content / uploads (or no slash at the beginning or at the end)
    2. Field: http://media.domain.com

    That’s all !
    Each uploaded image even go to the uploads folder and you can call it with the address media.domain.com/2016/09/test.jpg

    I’ve changed the directories to media/images thinking default naming might be creating a conflict.

    I have a subdomain media.mydomain.com and have uploaded all of the images to /media/images/ organized in year/month format respectively.

    I am seeing the images in the website, that path to images works.

    Any file path that I add into 1.Field of the plugin goes into the root and not the subdomain! It does this every time!

    I’ve gone into phpMyAdmin and looked at wp-options for uploads url and it is set to http://media.mydomain.com, but nothing is uploading to http://media.mydomain.com/media/images.

    Ok, I found this post (CLICK HERE) in your support threads, located the “webspace path for scripts” which for me is something like this: /home/primarydomain/public_html/media.mydomain.com/media/images

    I added that to upload_path of wp-options of the database by going to phpMyAdmin.
    I also added it to “Store uploads in this folder” field of the plugin.

    The second field of the plugin is the full URL path: http://media.mydomain.com/media/images

    Now it works!

    Before I found the upload_path and set it, the images I would upload would be an empty image icon, and would get loaded to this year/month default uploads folder. And if I set any uploads folder in the first field of the plugin, the plugin would generate a new upload directory inside the root.

    • This reply was modified 3 years, 10 months ago by benjammin.
    Plugin Author RVOLA

    (@rvola)

    happy to see resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not uploading to Subdomain’ is closed to new replies.